Browse Source

[goal] Migrate testing to ubuntu focal

As per victoria cycle testing runtime and community goal[1]
we need to migrate upstream CI/CD to Ubuntu Focal(20.04).

Bump the lower constraints for required deps which added
python3.8 support in their later version.

Story: #2007865
Task: #40199

[1] https://governance.openstack.org/tc/goals/selected/victoria/migrate-ci-cd-jobs-to-ubuntu-focal

Change-Id: Ie96f1049ea053200f3087eee81351848318727b2
tags/13.0.0.0rc1
manchandavishal 1 month ago
parent
commit
7ecd31f973
2 changed files with 6 additions and 6 deletions
  1. +5
    -5
      lower-constraints.txt
  2. +1
    -1
      test-requirements.txt

+ 5
- 5
lower-constraints.txt View File

@@ -7,12 +7,12 @@ Babel==2.3.4
beautifulsoup4==4.6.0
blockdiag==1.5.3
cachetools==2.0.0
cffi==1.7.0
cffi==1.14
cliff==2.8.0
cmd2==0.8.0
contextlib2==0.4.0
coverage==4.0
cryptography==2.1
cryptography==3.0
debtcollector==1.19.0
decorator==3.4.0
deprecation==1.0
@@ -31,7 +31,7 @@ fixtures==3.0.0
funcparserlib==0.3.6
future==0.16.0
futurist==1.2.0
greenlet==0.4.10
greenlet==0.4.15
horizon==17.1.0
httplib2==0.9.1
idna==2.6
@@ -101,7 +101,7 @@ Pint==0.5
positional==1.2.1
prettytable==0.7.2
psutil==3.2.2
psycopg2==2.7.7
psycopg2==2.8.5
pyasn1==0.1.8
pycadf==1.1.0
pycparser==2.18
@@ -109,7 +109,7 @@ Pygments==2.2.0
pyinotify==0.9.6
pymongo==3.0.2
PyMySQL==0.7.6
pyOpenSSL==17.1.0
pyOpenSSL==19.1.0
pyparsing==2.1.0
pyperclip==1.5.27
pyroute2==0.5.7


+ 1
- 1
test-requirements.txt View File

@@ -6,7 +6,7 @@ hacking>=3.0.0,<3.1 # Apache-2.0

coverage!=4.4,>=4.0 # Apache-2.0
python-subunit>=1.0.0 # Apache-2.0/BSD
psycopg2>=2.7.7 # LGPL/ZPL
psycopg2>=2.8.5 # LGPL/ZPL
PyMySQL>=0.7.6 # MIT License
WebOb>=1.8.2 # MIT
oslotest>=3.2.0 # Apache-2.0


Loading…
Cancel
Save