Browse Source

Drop nose dependencies

Horizon test setting no longer depends on nose and related stuffs.
This commit cleans up nose related dependencies.

The change was made in horizon Rocky-3,
so horizon 14.0.0.0b3 is required at least.

Filenames of test modules need to start with test_*
so that Django test runner detects them.
There is no test defined but it would be nice to adjust the filename.

Change-Id: I794e10b2c3c2c7004f7b58ff8c8904d4537a23d9
tags/10.0.0.0b1
Akihiro Motoki 10 months ago
parent
commit
892c9f980b
3 changed files with 0 additions and 3 deletions
  1. 0
    0
      bgpvpn_dashboard/test/api_tests/test_bgpvpn.py
  2. 0
    2
      lower-constraints.txt
  3. 0
    1
      test-requirements.txt

bgpvpn_dashboard/test/api_tests/bgpvpn_tests.py → bgpvpn_dashboard/test/api_tests/test_bgpvpn.py View File


+ 0
- 2
lower-constraints.txt View File

@@ -21,7 +21,6 @@ Django==1.8
21 21
 django-appconf==1.0.2
22 22
 django-babel==0.5.1
23 23
 django-compressor==2.0
24
-django-nose==1.4.4
25 24
 django-pyscss==2.0.2
26 25
 docutils==0.11
27 26
 dogpile.cache==0.6.2
@@ -66,7 +65,6 @@ networking-bagpipe==9.0.0
66 65
 networking-odl==12.0.0
67 66
 neutron==12.0.0
68 67
 neutron-lib==1.18.0
69
-nose==1.3.7
70 68
 openstacksdk==0.11.2
71 69
 os-client-config==1.28.0
72 70
 os-service-types==1.2.0

+ 0
- 1
test-requirements.txt View File

@@ -5,7 +5,6 @@
5 5
 hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
6 6
 
7 7
 coverage!=4.4,>=4.0 # Apache-2.0
8
-django-nose>=1.4.4 # BSD
9 8
 python-subunit>=1.0.0 # Apache-2.0/BSD
10 9
 psycopg2>=2.6.2 # LGPL/ZPL
11 10
 PyMySQL>=0.7.6 # MIT License

Loading…
Cancel
Save