Browse Source

Fix pep8 job

New versions of isort broke pylint. This patch fixes it at 4.3.21.
Make sure that siblings are installed for functional tests.

Change-Id: Id04da60731543d970de6a1a88da5a32435be1aae
changes/87/740287/6
elajkat 1 year ago
parent
commit
8c6564ffc4
  1. 5
      .zuul.yaml
  2. 1
      lower-constraints.txt
  3. 4
      requirements.txt
  4. 1
      test-requirements.txt

5
.zuul.yaml

@ -23,10 +23,13 @@
- openstack/neutron
- openstack/networking-bgpvpn
- openstack/networking-bagpipe
- openstack/networking-odl
- openstack/horizon
vars:
project_name: networking-bgpvpn
# NOTE(lajoskatona): neutron-functional sets tox_install_siblings to
# false. This needs to be true so for example neutron is installed into
# tox env from source.
tox_install_siblings: true
devstack_plugins:
networking-bgpvpn: https://opendev.org/openstack/networking-bgpvpn
neutron: https://opendev.org/openstack/neutron

1
lower-constraints.txt

@ -40,6 +40,7 @@ httplib2==0.9.1
idna==2.6
imagesize==0.7.1
iso8601==0.1.11
isort==4.3.21
Jinja2==2.10
jmespath==0.9.0
jsonpatch==1.16

4
requirements.txt

@ -13,7 +13,9 @@ debtcollector>=1.19.0 # Apache-2.0
# OpenStack CI will install the following projects from git
# if they are in the required-projects list for a job:
neutron>=13.0.0 # Apache-2.0
neutron>=16.0.0.0b1 # Apache-2.0
networking-bagpipe>=12.0.0.0rc1 # Apache-2.0
horizon>=17.1.0 # Apache-2.0
# The comment below indicates this project repo is current with neutron-lib
# and should receive neutron-lib consumption patches as they are released

1
test-requirements.txt

@ -18,6 +18,7 @@ testresources>=2.0.0 # Apache-2.0/BSD
testscenarios>=0.4 # Apache-2.0/BSD
testtools>=2.2.0 # MIT
tempest>=17.1.0 # Apache-2.0
isort==4.3.21 # MIT
# OpenStack CI will install the following projects from git
# if they are in the required-projects list for a job.

Loading…
Cancel
Save