Browse Source

Remove grenade jobs from old stable branches

As discussed and approved during the ironic wallaby midcycle, the grenade
jobs in old stable branches, starting from EM branches and up the oldest
not-EM (at this moment train) are removed.

Also multinode jobs are removed from EM branches.

And remove lower-constraints job.

Pin tempest to version 23.0.0 in Python 2.7 job.

Change-Id: I6728debb4e810f971eaa45f86565bbf822a335b2
changes/24/773324/2
Riccardo Pittau 3 months ago
parent
commit
a252b2fe93
2 changed files with 2 additions and 12 deletions
  1. +2
    -0
      zuul.d/networking-generic-switch-jobs.yaml
  2. +0
    -12
      zuul.d/project.yaml

+ 2
- 0
zuul.d/networking-generic-switch-jobs.yaml View File

@ -74,3 +74,5 @@
vars:
devstack_localrc:
USE_PYTHON3: False
TEMPEST_BRANCH: 23.0.0
TEMPEST_VENV_UPPER_CONSTRAINTS: "{{ devstack_base_dir }}/requirements/upper-constraints.txt"

+ 0
- 12
zuul.d/project.yaml View File

@ -10,20 +10,8 @@
jobs:
- networking-generic-switch-tempest-dlm
- networking-generic-switch-tempest-dlm-python2
- ironic-tempest-ipa-wholedisk-direct-tinyipa-multinode:
irrelevant-files:
- ^(test-|)requirements.txt$
- ^setup.cfg$
- ironic-grenade-dsvm-multinode-multitenant
- openstack-tox-lower-constraints
gate:
queue: networking-generic-switch
jobs:
- networking-generic-switch-tempest-dlm
- networking-generic-switch-tempest-dlm-python2
- ironic-tempest-ipa-wholedisk-direct-tinyipa-multinode:
irrelevant-files:
- ^(test-|)requirements.txt$
- ^setup.cfg$
- ironic-grenade-dsvm-multinode-multitenant
- openstack-tox-lower-constraints

Loading…
Cancel
Save