Browse Source

Use rally-openstack 1.7.0 for stable/rocky

Master branch now has requirements incompatible with stable branches
constraints [0], so this switches to last tag compatible.

Longer term fix will be to run rally in a virtualenv, but this is lower
priority than other tasks. This can be revisited at the time, though for
older branches we will probably stick with pinned version

Also pin neutron-tempest-plugin to latest version that supports python 2

[0] 5776e015f1

Change-Id: I54fb021dec49724f17e7b5a330e09bcc638310d6
Closes-Bug: #1868691
changes/33/715433/2
Bernard Cafarelli 3 months ago
parent
commit
4991184eca
No known key found for this signature in database GPG Key ID: 9531F08245465A52
2 changed files with 3 additions and 1 deletions
  1. +2
    -1
      zuul.d/legacy-networking-ovn-jobs.yaml
  2. +1
    -0
      zuul.d/networkin-ovn-rally-task.yaml

+ 2
- 1
zuul.d/legacy-networking-ovn-jobs.yaml View File

@@ -78,7 +78,8 @@
required-projects:
- openstack/devstack-gate
- openstack/networking-ovn
- openstack/neutron-tempest-plugin
- name: openstack/neutron-tempest-plugin
override-checkout: 0.9.0
- openstack/tempest

- job:


+ 1
- 0
zuul.d/networkin-ovn-rally-task.yaml View File

@@ -6,6 +6,7 @@
- name: openstack/devstack-gate
- name: openstack/rally
- name: openstack/rally-openstack
override-checkout: 1.7.0
- name: openstack/networking-ovn
irrelevant-files:
- ^(test-|)requirements.txt$


Loading…
Cancel
Save