Browse Source

Cap pycodestyle to be < 2.6.0

The 2.6.0 version introduces some checks that cause failures
with the current code. To avoid that, cap pycodestyle to a
version that had been tested without errors.

Had to remove cap on neutron in requirements.txt, but it
still used version 14.x.x in tests.

Change-Id: I00a35884b14af3e2cf751c04312c847ecfe658c7
(cherry picked from commit 719cae183a)
tags/6.1.0
Brian Haley 1 month ago
parent
commit
bd6dc2832f
2 changed files with 2 additions and 1 deletions
  1. +1
    -1
      requirements.txt
  2. +1
    -0
      test-requirements.txt

+ 1
- 1
requirements.txt View File

@@ -14,7 +14,7 @@ pyOpenSSL>=17.1.0 # Apache-2.0
tenacity>=4.4.0 # Apache-2.0
Babel!=2.4.0,>=2.3.4 # BSD
six>=1.10.0 # MIT
neutron>=13.0.0.0b2,<15.0.0.0b1 # Apache-2.0
neutron>=13.0.0.0b2 # Apache-2.0
octavia-lib>=1.1.1 # Apache-2.0
requests!=2.20.0,>=2.14.2 # Apache-2.0



+ 1
- 0
test-requirements.txt View File

@@ -7,6 +7,7 @@ hacking>=1.1.0 # Apache-2.0
bandit>=1.1.0,<1.6.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
flake8-import-order==0.12 # LGPLv3
pycodestyle>=2.0.0,<2.6.0 # MIT
python-subunit>=1.0.0 # Apache-2.0/BSD
oslotest>=3.2.0 # Apache-2.0
os-testr>=1.0.0 # Apache-2.0


Loading…
Cancel
Save