Browse Source

Fix PEP8 CI breakage

The infer_name_module() method was removed from astroid in the version
2.2.0 [0] (astroid is blacklisted in openstack/requirements, so we do
not constraint it). That method was then moved to pylint which we do
constainst so, this patch is updating the version of pylint (to the one
that includes that method) and fixing few pep8 errors as well.

[0]
51891dc817

Change-Id: I871b442b62b83d28e7d0cacd9bd4dad388e50e88
Signed-off-by: Lucas Alvares Gomes <lucasagomes@gmail.com>
Lucas Alvares Gomes 2 months ago
parent
commit
c373b58c21

+ 0
- 2
networking_ovn/l3/l3_ovn_scheduler.py View File

@@ -44,7 +44,6 @@ class OVNGatewayScheduler(object):
44 44
         Schedule the gateway router port only if it is not already
45 45
         scheduled.
46 46
         """
47
-        pass
48 47
 
49 48
     def _schedule_gateway(self, nb_idl, sb_idl, gateway_name, candidates):
50 49
         existing_chassis = nb_idl.get_gateway_chassis_binding(gateway_name)
@@ -71,7 +70,6 @@ class OVNGatewayScheduler(object):
71 70
     @abc.abstractmethod
72 71
     def _select_gateway_chassis(self, nb_idl, candidates):
73 72
         """Choose a chassis from candidates based on a specific policy."""
74
-        pass
75 73
 
76 74
     def _get_chassis_candidates(self, sb_idl):
77 75
         # TODO(azbiswas): Allow selection of a specific type of chassis when

+ 1
- 1
networking_ovn/ovsdb/ovsdb_monitor.py View File

@@ -333,9 +333,9 @@ class OvnIdl(BaseOvnIdl):
333 333
             return
334 334
         self.notify_handler.notify(event, row, updates)
335 335
 
336
+    @abc.abstractmethod
336 337
     def post_connect(self):
337 338
         """Should be called after the idl has been initialized"""
338
-        pass
339 339
 
340 340
 
341 341
 class OvnNbIdl(OvnIdl):

+ 1
- 1
test-requirements.txt View File

@@ -13,7 +13,7 @@ doc8>=0.6.0 # Apache-2.0
13 13
 oslotest>=3.2.0 # Apache-2.0
14 14
 os-testr>=1.0.0 # Apache-2.0
15 15
 pylint==1.9.3;python_version=='2.7' # GPLv2
16
-pylint==2.1.1;python_version>='3.0' # GPLv2
16
+pylint==2.3.0;python_version>='3.0' # GPLv2
17 17
 octavia-lib>=1.0.0
18 18
 testresources>=2.0.0 # Apache-2.0/BSD
19 19
 testscenarios>=0.4 # Apache-2.0/BSD

Loading…
Cancel
Save