Manual sync with upstream requirements

Bump the reqs/test-reqs to the latest from the upstream
global requirements project.

Change-Id: Ie75a8ed3e2391a3279609bb3cee7afe4352f460d
changes/20/452220/2
Adam Reznechek 6 years ago
parent a9f6adf316
commit d92033c486

@ -1,7 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
amqp>=1.4.0 # LGPL
amqp!=2.1.4,>=2.1.0 # BSD
pbr>=2.0.0 # Apache-2.0
Routes!=2.0,!=2.1,!=2.3.0,>=1.12.3;python_version=='2.7' # MIT
@ -9,11 +9,11 @@ Routes!=2.0,!=2.3.0,>=1.12.3;python_version!='2.7' # MIT
eventlet!=0.18.3,>=0.18.2 # MIT
greenlet>=0.3.2 # MIT
six>=1.9.0 # MIT
oslo.log>=3.11.0 # Apache-2.0
oslo.log>=3.22.0 # Apache-2.0
oslo.serialization>=1.10.0 # Apache-2.0
oslo.service>=1.10.0 # Apache-2.0
oslo.utils>=3.20.0 # Apache-2.0
oslo.config!=3.18.0,>=3.14.0 # Apache-2.0
pypowervm
setuptools!=24.0.0,!=34.0.0,!=34.0.1,!=34.0.2,!=34.0.3,!=34.1.0,!=34.1.1,!=34.2.0,!=34.3.0,>=16.0 # PSF/ZPL
neutron-lib>=1.2.0 # Apache-2.0
oslo.config>=3.22.0 # Apache-2.0
pypowervm>=1.1.1 # Apache-2.0
setuptools!=24.0.0,!=34.0.0,!=34.0.1,!=34.0.2,!=34.0.3,!=34.1.0,!=34.1.1,!=34.2.0,!=34.3.0,!=34.3.1,!=34.3.2,>=16.0 # PSF/ZPL
neutron-lib>=1.3.0 # Apache-2.0

@ -1,5 +1,4 @@
#!/usr/bin/env python
# Copyright 2014 IBM Corp.
# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@ -26,5 +25,5 @@ except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=1.8'],
setup_requires=['pbr>=2.0.0'],
pbr=True)

@ -5,7 +5,6 @@ hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
bashate>=0.2 # Apache-2.0
coverage>=4.0 # Apache-2.0
discover # BSD
fixtures>=3.0.0 # Apache-2.0/BSD
python-subunit>=0.0.18 # Apache-2.0/BSD
testrepository>=0.0.18 # Apache-2.0/BSD

Loading…
Cancel
Save