Browse Source

Fix requirements

1. remove unused requirement: mock-requests. This is due to the fact
   that is is unused.
2. Update sphinx
3. Uncap evenlet: uncap eventlet. We will manage the eventlet
   version using constraints now. See the thread starting at
   http://lists.openstack.org/pipermail/openstack-dev/2018-April/129096.html
   for more details.
4. Update RYU to be 4.24 to sort out issues with pip 10

Co-Authored-By: Doug Hellmann <doug@doughellmann.com>

Change-Id: I855f88ca09a735054c3582f16d8eff977dc53ce1
changes/43/561443/6 13.0.0.0b1
Gary Kotton 3 years ago
committed by garyk
parent
commit
04bcb0853c
  1. 3
      lower-constraints.txt
  2. 2
      requirements.txt
  3. 5
      test-requirements.txt

3
lower-constraints.txt

@ -116,11 +116,10 @@ PyYAML==3.12
reno==2.5.0
repoze.lru==0.7
requests==2.14.2
requests-mock==1.1.0
requestsexceptions==1.2.0
rfc3986==0.3.1
Routes==2.3.1
ryu==4.14
ryu==4.24
simplejson==3.5.1
six==1.10.0
snowballstemmer==1.2.1

2
requirements.txt

@ -3,7 +3,7 @@
# process, which may cause wedges in the gate later.
pbr!=2.1.0,>=2.0.0 # Apache-2.0
eventlet!=0.18.3,!=0.20.1,<0.21.0,>=0.18.2 # MIT
eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
httplib2>=0.9.1 # MIT
netaddr>=0.7.18 # BSD
SQLAlchemy!=1.1.5,!=1.1.6,!=1.1.7,!=1.1.8,>=1.0.10 # MIT

5
test-requirements.txt

@ -8,8 +8,7 @@ fixtures>=3.0.0 # Apache-2.0/BSD
flake8-import-order==0.12 # LGPLv3
mock>=2.0.0 # BSD
python-subunit>=1.0.0 # Apache-2.0/BSD
requests-mock>=1.2.0 # Apache-2.0
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.5 # BSD
openstackdocstheme>=1.18.1 # Apache-2.0
oslo.concurrency>=3.25.0 # Apache-2.0
os-testr>=1.0.0 # Apache-2.0
@ -21,4 +20,4 @@ WebTest>=2.0.27 # MIT
oslotest>=3.2.0 # Apache-2.0
reno>=2.5.0 # Apache-2.0
tempest>=17.1.0 # Apache-2.0
ryu>=4.14 # Apache-2.0
ryu>=4.24 # Apache-2.0
Loading…
Cancel
Save