Browse Source

Drop nose dependencies

Horizon test setting no longer depends on nose and related stuffs.
This commit cleans up nose related dependencies.

The change was made in horizon Rocky-3,
so horizon 14.0.0.0b3 is required at least.

Change-Id: I9e55d157dd1c11037cdd522cce9065d84830ff6d
changes/47/593147/1
Akihiro Motoki 3 years ago
parent
commit
0f499eb611
  1. 5
      lower-constraints.txt
  2. 2
      requirements.txt
  3. 2
      test-requirements.txt

5
lower-constraints.txt

@ -17,7 +17,6 @@ Django==1.8
django-appconf==1.0.2
django-babel==0.5.1
django-compressor==2.0
django-nose==1.4.4
django-pyscss==2.0.2
dogpile.cache==0.6.2
eventlet==0.18.2
@ -28,7 +27,7 @@ flake8==2.5.5
futurist==1.2.0
greenlet==0.4.10
hacking==0.12.0
horizon==13.0.0
horizon==14.0.0.0b3
idna==2.6
iso8601==0.1.11
Jinja2==2.10
@ -48,8 +47,6 @@ msgpack-python==0.4.0
munch==2.1.0
netaddr==0.7.18
netifaces==0.10.4
nose==1.3.7
nose-exclude==0.3.0
openstacksdk==0.11.2
os-client-config==1.28.0
os-service-types==1.2.0

2
requirements.txt

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
horizon>=13.0.0 # Apache-2.0
horizon>=14.0.0.0b3 # Apache-2.0
oslo.log>=3.36.0 # Apache-2.0
pbr!=2.1.0,>=2.0.0 # Apache-2.0
Babel!=2.4.0,>=2.3.4 # BSD

2
test-requirements.txt

@ -5,9 +5,7 @@
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
ddt>=1.0.1 # MIT
django-nose>=1.4.4 # BSD
python-subunit>=1.0.0 # Apache-2.0/BSD
nose-exclude>=0.3.0 # LGPL
selenium>=2.50.1 # Apache-2.0
oslotest>=3.2.0 # Apache-2.0
testscenarios>=0.4 # Apache-2.0/BSD

Loading…
Cancel
Save