Browse Source

Remove the references to oslosphinx

oslosphinx is deprecated, fails with sphinx 2, and is going away.
This updates neutron-lbaas to use a basic openstackdocstheme.

Change-Id: Iffc66fecd1b94a2cd94ec7da27bb273784644c0b
Michael Johnson 2 weeks ago
parent
commit
da74ad0428
3 changed files with 1 additions and 3 deletions
  1. 0
    1
      doc/requirements.txt
  2. 1
    1
      doc/source/conf.py
  3. 0
    1
      lower-constraints.txt

+ 0
- 1
doc/requirements.txt View File

@@ -1,4 +1,3 @@
1 1
 sphinx>=1.6.2 # BSD
2
-oslosphinx>=4.7.0 # Apache-2.0
3 2
 openstackdocstheme>=1.17.0 # Apache-2.0
4 3
 reno>=2.5.0 # Apache-2.0

+ 1
- 1
doc/source/conf.py View File

@@ -48,7 +48,7 @@ extensions = ['sphinx.ext.autodoc',
48 48
               'sphinx.ext.ifconfig',
49 49
               'sphinx.ext.graphviz',
50 50
               'sphinx.ext.todo',
51
-              'oslosphinx']
51
+              'openstackdocstheme']
52 52
 
53 53
 todo_include_todos = True
54 54
 

+ 0
- 1
lower-constraints.txt View File

@@ -78,7 +78,6 @@ oslo.serialization==2.18.0
78 78
 oslo.service==1.24.0
79 79
 oslo.utils==3.33.0
80 80
 oslo.versionedobjects==1.31.2
81
-oslosphinx==4.7.0
82 81
 oslotest==3.2.0
83 82
 osprofiler==1.4.0
84 83
 ovs==2.8.0

Loading…
Cancel
Save