Browse Source

Sync Sphinx requirement

1. Sync sphinx dependency with global requirements. It caps python 2 since
sphinx 2.0 no longer supports Python 2.7.
2. Remove unncessary "=="

Change-Id: Id733fe1f513e756eb7bb2e8314bdb5dacc5dacd3
tags/0.4.0
jacky06 4 months ago
parent
commit
25cea25f12
3 changed files with 6 additions and 5 deletions
  1. 1
    1
      HACKING.rst
  2. 3
    3
      releasenotes/source/index.rst
  3. 2
    1
      test-requirements.txt

+ 1
- 1
HACKING.rst View File

@@ -1,4 +1,4 @@
openstack Style Commandments
===============================================
============================

Read the OpenStack Style Commandments https://docs.openstack.org/hacking/latest/

+ 3
- 3
releasenotes/source/index.rst View File

@@ -1,6 +1,6 @@
======================================
Neutron Tempest Plugin Release Notes
======================================
====================================
Neutron Tempest Plugin Release Notes
====================================

.. toctree::
:maxdepth: 1

+ 2
- 1
test-requirements.txt View File

@@ -7,7 +7,8 @@ hacking<0.13,>=0.12.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
flake8-import-order==0.12 # LGPLv3
python-subunit>=1.0.0 # Apache-2.0/BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
oslotest>=3.2.0 # Apache-2.0
stestr>=1.0.0 # Apache-2.0
testtools>=2.2.0 # MIT

Loading…
Cancel
Save