Browse Source

Use rally 0.12.1 release for stable/queens branch.

Rally does not have any alignment of own tags to OpenStack releases.
In theory it should be possible to launch the latest Rally against
old clouds.

To follow the common processes and policy, Rally synchronized own
dependencies (python-*client's and oslo.* libs) with g-r. It made a
conflict between installed versions by stable/queens@devstack and
rally itself.
With Rally master branch it became an error (Rally's team is
working on moving in-tree OpenStack plugins to the separate repository
openstack/rally-openstack).
Rally 0.12.1 is the latest release which doesn't contain a breaking
change.

Ideally, to avoid such issues in future, Rally devstack plugin and
zuul job should install Rally in a virtual environment, but such
change requires more time for investigation and implementation.

So this patch is a quick workaround to avoid version conflict
of python dependencies.

Change-Id: I73ef5c978e66a89bb70be28468e0d1f40a71d94f
Closes-Bug: #1778714
(cherry picked from commit a4233220d8)
tags/12.0.4
Slawek Kaplonski 2 years ago
committed by Boden R
parent
commit
26894447b3
1 changed files with 1 additions and 1 deletions
  1. +1
    -1
      .zuul.yaml

+ 1
- 1
.zuul.yaml View File

@@ -78,7 +78,7 @@
- openstack/python-senlinclient
- openstack/python-watcherclient
- openstack/python-zaqarclient
- openstack/rally
- {"name": "openstack/rally", "override-checkout": "0.12.1"}
- openstack/senlin
- openstack/tripleo-image-elements
- openstack/watcher


Loading…
Cancel
Save