Add tunnel_ip_version to tunnel_sync() error message

Just to make it clear in the message, add the
tunnel_ip_version config option in the error
message, else the user has to consult the startup
message to know what the value is set to.

Trivialfix

Change-Id: Ic8d8b0d454e8202d1bfae52b77137eb9071508da
changes/02/716802/1
Brian Haley 3 years ago
parent 49dd7007b5
commit 3e2b15f0d6
  1. 6
      neutron/plugins/ml2/drivers/type_tunnel.py

@ -501,8 +501,10 @@ class TunnelRpcCallbackMixin(object):
version = netaddr.IPAddress(tunnel_ip).version
if version != cfg.CONF.ml2.overlay_ip_version:
msg = (_("Tunnel IP version does not match ML2 "
"overlay_ip_version, host: %(host)s, tunnel_ip: %(ip)s"),
{'host': host, 'ip': tunnel_ip})
"overlay_ip_version: %(overlay)s, host: %(host)s, "
"tunnel_ip: %(ip)s"),
{'overlay': cfg.CONF.ml2.overlay_ip_version,
'host': host, 'ip': tunnel_ip})
raise exc.InvalidInput(error_message=msg)
tunnel_type = kwargs.get('tunnel_type')

Loading…
Cancel
Save