Browse Source

Cap pycodestyle to be < 2.6.0

The 2.6.0 version introduces some checks that cause failures
with the current code. To avoid that, cap pycodestyle to a
version that had been tested without errors.

In Rocky we already had tests with pycodestyle, but proper listing in
test-requirements.txt was only added in
I33be4f5d4ae48c6bd48d80e3f1185ef8307a2a0c

Conflicts:
	test-requirements.txt

Change-Id: I00a35884b14af3e2cf751c04312c847ecfe658c7
(cherry picked from commit 719cae183a)
changes/05/727805/1
Brian Haley 1 month ago
committed by Bernard Cafarelli
parent
commit
5caa8f6d7e
No known key found for this signature in database GPG Key ID: 9531F08245465A52
1 changed files with 1 additions and 0 deletions
  1. +1
    -0
      test-requirements.txt

+ 1
- 0
test-requirements.txt View File

@@ -7,6 +7,7 @@ bandit>=1.1.0,<1.5.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
flake8-import-order==0.12 # LGPLv3
pycodestyle>=2.0.0,<2.6.0 # MIT
mock>=2.0.0 # BSD
python-subunit>=1.0.0 # Apache-2.0/BSD
testtools>=2.2.0 # MIT


Loading…
Cancel
Save