Browse Source

Use openstack-python3-train-jobs template

This goal is to implement the process set out in the 2018-10-24 Python
Update Process TC resolution[1], for the Train cycle to ensure unit
testing is in place for all of the Tested Runtimes for Train[2].
In practice, this generally means adding unit tests for Python 3.7 and
dropping unit tests for Python 3.5.
For Neutron, which already runs py36 and py37 unit tests it generally
means switch to use the Zuul template openstack-python3-train-jobs
for Train.
Using this template will ensure that all projects that support Python3
will be tested against the agreed runtime versions, and make it easier
to update them in future.

[1]https://governance.openstack.org/tc/resolutions/20181024-python-update-process.html
[2]https://governance.openstack.org/tc/reference/runtimes/train.html

Change-Id: I41d232a10a40d97347566e189457d8044e3639db
Depends-On: https://review.opendev.org/#/c/641878/
changes/40/657940/4
ZhongShengping 2 years ago
committed by Slawek Kaplonski
parent
commit
5f5918df8b
3 changed files with 3 additions and 3 deletions
  1. +1
    -2
      .zuul.yaml
  2. +1
    -0
      setup.cfg
  3. +1
    -1
      tox.ini

+ 1
- 2
.zuul.yaml View File

@ -4,8 +4,7 @@
- openstack-cover-jobs
- openstack-lower-constraints-jobs
- openstack-python-jobs
- openstack-python36-jobs
- openstack-python37-jobs
- openstack-python3-train-jobs
- publish-openstack-docs-pti
- periodic-stable-jobs
- check-requirements


+ 1
- 0
setup.cfg View File

@ -17,6 +17,7 @@ classifier =
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
[files]
packages =


+ 1
- 1
tox.ini View File

@ -1,5 +1,5 @@
[tox]
envlist = docs,py36,py27,pep8
envlist = docs,py36,py37,py27,pep8
minversion = 2.3.2
skipsdist = True


Loading…
Cancel
Save