Browse Source

Force segments to use placement 1.1

By documentation segments plugin was designed to use placement
microversion 1.1, force to use that.

Change-Id: Ibb8d6bcce7f0fe1070b9eeb2ad632dfb58a3a015
Depends-On: https://review.opendev.org/663978
Related-Bug: #1828543
tags/15.0.0.0b1
elajkat 1 year ago
parent
commit
62f55a12b0
1 changed files with 2 additions and 1 deletions
  1. +2
    -1
      neutron/services/segments/plugin.py

+ 2
- 1
neutron/services/segments/plugin.py View File

@@ -157,7 +157,8 @@ class NovaSegmentNotifier(object):
cfg.CONF.send_events_interval, self._send_notifications)

def _get_clients(self):
p_client = placement_client.PlacementAPIClient(cfg.CONF)
p_client = placement_client.PlacementAPIClient(
cfg.CONF, openstack_api_version='placement 1.1')

n_auth = ks_loading.load_auth_from_conf_options(cfg.CONF, 'nova')
n_session = ks_loading.load_session_from_conf_options(


Loading…
Cancel
Save