Browse Source

Cap pycodestyle to be < 2.6.0

The 2.6.0 version introduces some checks that cause failures
with the current code. To avoid that, cap pycodestyle to a
version that had been tested without errors.

Change-Id: I00a35884b14af3e2cf751c04312c847ecfe658c7
changes/74/727274/3
Brian Haley 1 year ago
parent
commit
719cae183a
  1. 2
      test-requirements.txt

2
test-requirements.txt

@ -6,7 +6,7 @@ bandit!=1.6.0,>=1.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
flake8-import-order==0.12 # LGPLv3
pycodestyle>=2.0.0 # MIT
pycodestyle>=2.0.0,<2.6.0 # MIT
mock>=3.0.0 # BSD
python-subunit>=1.0.0 # Apache-2.0/BSD
testtools>=2.2.0 # MIT

Loading…
Cancel
Save