Browse Source

Add libffi-dev to bindep.txt

libffi-dev is required to install cffi and PyNaCL from tarballs.
cffi is installed from requirements.txt, so 'test' profile is not
specified.

We usual use wheel packages when installing python packages,
but tarball is sometimes used, for example, when a new version
is uploaded. I think it is worth adding it to bindep.txt
to avoid accidental gate failure.

Closes-Bug: #1697613
Change-Id: I4800c9f213fa5c8f28c8603e022264e6aa139090
tags/11.0.0.0b3
Akihiro Motoki 2 years ago
parent
commit
8e8f721f6f
1 changed files with 4 additions and 0 deletions
  1. +4
    -0
      bindep.txt

+ 4
- 0
bindep.txt View File

@@ -4,6 +4,10 @@
# tools/misc-sanity-checks.sh validates .po[t] files
gettext [test]

# cffi (required by oslo.privsep) and PyNaCL (required by paramiko)
libffi-dev [platform:dpkg]
libffi-devel [platform:rpm]

# MySQL and PostgreSQL databases since some jobs are set up in
# OpenStack infra that need these like
# periodic-neutron-py27-with-oslo-master and

Loading…
Cancel
Save