Browse Source

[train] Fix tests with new pip resolver

Bump minimum keystoneauth1 as openstacksdk needs a newer version
Bump minimum debtcollerctor, ovsdbapp as os-vif needs a newer version
In lower-constraints, bump os-service-types, and fix pycodestyle bound
to align with test requirements

This change also caps bandit to <= 1.6.2 after the now yanked 1.6.3
release dropped py27 support [1][2]. 1.7.0 has since been released [3]
but is still present in the universal wheel and thus will be pulled in
by py27 incorrectly.

Also disable networking-ovn-tempest-dsvm-ovs-release job to allow
https://review.opendev.org/c/openstack/networking-ovn/+/767424 fix to
merge (they depend on each other), follow-up patch will restore it

[1] https://github.com/PyCQA/bandit/releases/tag/1.6.3
[2] https://github.com/PyCQA/bandit/pull/615
[3] https://github.com/PyCQA/bandit/releases/tag/1.7.0

Depends-On: https://review.opendev.org/c/openstack/devstack/+/768256
Depends-On: https://review.opendev.org/c/openstack/swift/+/766214

Change-Id: Idb98850d1ef09e4ae82b42a7f1930b99ae74e0a1
changes/87/767287/7
Bernard Cafarelli 6 months ago
parent
commit
c9416b1013
No known key found for this signature in database GPG Key ID: 9531F08245465A52
4 changed files with 13 additions and 11 deletions
  1. +4
    -2
      .zuul.yaml
  2. +5
    -5
      lower-constraints.txt
  3. +3
    -3
      requirements.txt
  4. +1
    -1
      test-requirements.txt

+ 4
- 2
.zuul.yaml View File

@ -45,8 +45,10 @@
irrelevant-files: *tempest-irrelevant-files
- tempest-slow-py3:
irrelevant-files: *tempest-irrelevant-files
- networking-ovn-tempest-dsvm-ovs-release:
irrelevant-files: *tempest-irrelevant-files
# TODO(bcafarel): disable this job to get pip resolver fixes in for
# neutron and networking-ovn (as fixes depend on each other)
#- networking-ovn-tempest-dsvm-ovs-release:
# irrelevant-files: *tempest-irrelevant-files
- networking-midonet-tempest-aio-ml2-centos-7:
voting: false
irrelevant-files: *tempest-irrelevant-files


+ 5
- 5
lower-constraints.txt View File

@ -14,7 +14,7 @@ cmd2==0.8.0
contextlib2==0.4.0
coverage==4.0
ddt==1.0.1
debtcollector==1.2.0
debtcollector==1.19.0
decorator==3.4.0
deprecation==1.0
docutils==0.11
@ -41,7 +41,7 @@ jmespath==0.9.0
jsonpatch==1.16
jsonpointer==1.13
jsonschema==2.6.0
keystoneauth1==3.4.0
keystoneauth1==3.14.0
keystonemiddleware==4.17.0
kombu==4.0.0
linecache2==1.0.0
@ -62,7 +62,7 @@ openstackdocstheme==1.30.0
openstacksdk==0.31.2
os-client-config==1.28.0
os-ken==0.3.0
os-service-types==1.2.0
os-service-types==1.7.0
os-vif==1.15.1
os-xenapi==0.3.1
osc-lib==1.8.0
@ -87,7 +87,7 @@ oslo.versionedobjects==1.35.1
oslotest==3.2.0
osprofiler==2.3.0
ovs==2.8.0
ovsdbapp==0.9.1
ovsdbapp==0.12.1
Paste==2.0.2
PasteDeploy==1.5.0
pbr==4.0.0
@ -99,7 +99,7 @@ positional==1.2.1
prettytable==0.7.2
psutil==3.2.2
pycadf==1.1.0
pycodestyle==2.4.0
pycodestyle==2.0.0
pycparser==2.18
pyflakes==0.8.1
Pygments==2.2.0


+ 3
- 3
requirements.txt View File

@ -6,7 +6,7 @@ pbr>=4.0.0 # Apache-2.0
Paste>=2.0.2 # MIT
PasteDeploy>=1.5.0 # MIT
Routes>=2.3.1 # MIT
debtcollector>=1.2.0 # Apache-2.0
debtcollector>=1.19.0 # Apache-2.0
decorator>=3.4.0 # BSD
eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
pecan>=1.3.2 # BSD
@ -21,7 +21,7 @@ python-neutronclient>=6.7.0 # Apache-2.0
tenacity>=3.2.1 # Apache-2.0
SQLAlchemy>=1.2.0 # MIT
WebOb>=1.8.2 # MIT
keystoneauth1>=3.4.0 # Apache-2.0
keystoneauth1>=3.14.0 # Apache-2.0
alembic>=0.8.10 # MIT
six>=1.10.0 # MIT
stevedore>=1.20.0 # Apache-2.0
@ -46,7 +46,7 @@ oslo.versionedobjects>=1.35.1 # Apache-2.0
osprofiler>=2.3.0 # Apache-2.0
os-ken >= 0.3.0 # Apache-2.0
ovs>=2.8.0 # Apache-2.0
ovsdbapp>=0.9.1 # Apache-2.0
ovsdbapp>=0.12.1 # Apache-2.0
psutil>=3.2.2 # BSD
pyroute2>=0.5.3;sys_platform!='win32' # Apache-2.0 (+ dual licensed GPL2)
weakrefmethod>=1.0.2;python_version=='2.7' # PSF


+ 1
- 1
test-requirements.txt View File

@ -3,7 +3,7 @@
# process, which may cause wedges in the gate later.
hacking>=1.1.0,<1.2.0 # Apache-2.0
bandit!=1.6.0,>=1.1.0 # Apache-2.0
bandit!=1.6.0,>=1.1.0,<=1.6.2 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
flake8-import-order==0.12 # LGPLv3


Loading…
Cancel
Save