Browse Source

Stop configuring install_command in tox.

Currently, we are overriding 'install_command' to use 'pip'. This is
considered poor behavior and 'python -m pip' should be used instead:

https://snarky.ca/why-you-should-use-python-m-pip/

It turns out that this is the the default value provided by tox:

https://tox.readthedocs.io/en/latest/config.html#conf-install_command

So we can remove the line and simply use the default value.
This change showed we needed a newer version of debtcollector in lower
constraints, aliging with the version required by os-vif. This change
showed we needed also a newer version of cffi and keystoneauth1 in lower
constraints. Update also the requirements file for debtcollector and
keystoneauth1.

Change-Id: I5e190c3db8bed0a264b911cdf425aa4c9b51f768
changes/68/694568/16
Daniel Bengtsson 2 years ago
parent
commit
f8a3b2c589
3 changed files with 7 additions and 9 deletions
  1. +4
    -4
      lower-constraints.txt
  2. +2
    -2
      requirements.txt
  3. +1
    -3
      tox.ini

+ 4
- 4
lower-constraints.txt View File

@ -8,13 +8,13 @@ bandit==1.1.0
bashate==0.5.1
beautifulsoup4==4.6.0
cachetools==2.0.0
cffi==1.7.0
cffi==1.13.2
cliff==2.8.0
cmd2==0.8.0
contextlib2==0.4.0
coverage==4.0
ddt==1.0.1
debtcollector==1.2.0
debtcollector==1.19.0
decorator==3.4.0
deprecation==1.0
doc8==0.6.0
@ -41,7 +41,7 @@ jmespath==0.9.0
jsonpatch==1.16
jsonpointer==1.13
jsonschema==2.6.0
keystoneauth1==3.4.0
keystoneauth1==3.14.0
keystonemiddleware==4.17.0
kombu==4.0.0
linecache2==1.0.0
@ -62,7 +62,7 @@ openstackdocstheme==1.30.0
openstacksdk==0.31.2
os-client-config==1.28.0
os-ken==0.3.0
os-service-types==1.2.0
os-service-types==1.7.0
os-vif==1.15.1
os-xenapi==0.3.1
osc-lib==1.8.0


+ 2
- 2
requirements.txt View File

@ -6,7 +6,7 @@ pbr>=4.0.0 # Apache-2.0
Paste>=2.0.2 # MIT
PasteDeploy>=1.5.0 # MIT
Routes>=2.3.1 # MIT
debtcollector>=1.2.0 # Apache-2.0
debtcollector>=1.19.0 # Apache-2.0
decorator>=3.4.0 # BSD
eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
pecan>=1.3.2 # BSD
@ -21,7 +21,7 @@ python-neutronclient>=6.7.0 # Apache-2.0
tenacity>=4.4.0 # Apache-2.0
SQLAlchemy>=1.2.0 # MIT
WebOb>=1.8.2 # MIT
keystoneauth1>=3.4.0 # Apache-2.0
keystoneauth1>=3.14.0 # Apache-2.0
alembic>=0.8.10 # MIT
six>=1.10.0 # MIT
stevedore>=1.20.0 # Apache-2.0


+ 1
- 3
tox.ini View File

@ -1,6 +1,6 @@
[tox]
envlist = docs,py37,pep8
minversion = 3.1.0
minversion = 3.2.0
skipsdist = True
ignore_basepython_conflict = True
@ -13,8 +13,6 @@ setenv = VIRTUAL_ENV={envdir}
PYTHONWARNINGS=default::DeprecationWarning,ignore::DeprecationWarning:distutils,ignore::DeprecationWarning:site
passenv = TRACE_FAILONLY GENERATE_HASHES http_proxy HTTP_PROXY https_proxy HTTPS_PROXY no_proxy NO_PROXY TOX_ENV_SRC_MODULES
usedevelop = True
install_command =
pip install {opts} {packages}
deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master}
-r{toxinidir}/requirements.txt


Loading…
Cancel
Save