Browse Source

Change sqlalchemy warnings filter to an error

The warning should be gone with change
I192e84ce757d12d33085a209dd58d8ea46fb90fb in
oslo.db 4.44.0 so this changes the warnings
filter from ignore to error and bumps the minimum
required version of oslo.db to include that change.

Change-Id: If7b1a9613b58476fab8409211512613a8863cdde
Related-Bug: #1813147
Related-Bug: #1814199
tags/19.0.0.0rc1
Matt Riedemann 9 months ago
parent
commit
0840bcccc0
3 changed files with 3 additions and 5 deletions
  1. +1
    -1
      lower-constraints.txt
  2. +1
    -3
      nova/tests/fixtures.py
  3. +1
    -1
      requirements.txt

+ 1
- 1
lower-constraints.txt View File

@@ -78,7 +78,7 @@ oslo.cache==1.26.0
oslo.concurrency==3.26.0
oslo.config==6.1.0
oslo.context==2.19.2
oslo.db==4.40.0
oslo.db==4.44.0
oslo.i18n==3.15.3
oslo.log==3.36.0
oslo.messaging==6.3.0

+ 1
- 3
nova/tests/fixtures.py View File

@@ -837,10 +837,8 @@ class WarningsFixture(fixtures.Fixture):
"._Default object at ",
category=UserWarning)

# TODO(mriedem): Change (or remove) this SAWarning to an error once
# https://bugs.launchpad.net/oslo.db/+bug/1814199 is fixed.
warnings.filterwarnings(
'ignore', message='Evaluating non-mapped column expression',
'error', message='Evaluating non-mapped column expression',
category=sqla_exc.SAWarning)

# TODO(jangutter): Change (or remove) this to an error during the Train

+ 1
- 1
requirements.txt View File

@@ -44,7 +44,7 @@ oslo.reports>=1.18.0 # Apache-2.0
oslo.serialization!=2.19.1,>=2.21.1 # Apache-2.0
oslo.upgradecheck>=0.1.1
oslo.utils>=3.37.0 # Apache-2.0
oslo.db>=4.40.0 # Apache-2.0
oslo.db>=4.44.0 # Apache-2.0
oslo.rootwrap>=5.8.0 # Apache-2.0
oslo.messaging>=6.3.0 # Apache-2.0
oslo.policy>=1.35.0 # Apache-2.0

Loading…
Cancel
Save