Browse Source

Merge "Add note and daxio version to the vPMEM document" into stable/ussuri

changes/49/751349/1
Zuul 3 weeks ago
committed by Gerrit Code Review
parent
commit
173416decb
1 changed files with 11 additions and 0 deletions
  1. +11
    -0
      doc/source/admin/virtual-persistent-memory.rst

+ 11
- 0
doc/source/admin/virtual-persistent-memory.rst View File

@@ -31,12 +31,23 @@ The following are required to support the vPMEM feature:

``dax_pmem``, ``nd_pmem``, ``device_dax``, ``nd_btt``

.. note::

NVDIMM support is present in the Linux Kernel v4.0 or newer. It is
recommended to use Kernel version 4.2 or later since `NVDIMM support
<https://docs.pmem.io/persistent-memory/getting-started-guide/creating-development-environments/linux-environments>`_
is enabled by default. We met some bugs in older versions, and we have
done all verification works with OpenStack on 4.18 version, so 4.18
version and newer will probably guarantee its functionality.

* QEMU version >= 3.1.0

* Libvirt version >= 5.0.0

* `ndctl`_ version >= 62

* daxio version >= 1.6

The vPMEM feature has been verified under the software and hardware listed above.




Loading…
Cancel
Save