Browse Source

Pick next minimum libvirt / QEMU versions for "Stein"

The last time we incremented versions for libvirt and QEMU was during
the "Pike" release (commit: b980df0, 11-Feb-2017); for "Queens" we
didn't do any.  The advertized NEXT_MIN_{LIBVIRT,QEMU} versions during
"Pike" release were set to: libvirt 1.3.1 and QEMU 2.5.0 -- but they
weren't actually bumped for "Queens".  They will be applied for the
"Rocky" release.

Based on the LibvirtDistroSupportMatrix[*], this patch announces a
version increment for libvirt and QEMU that will be applied for the
"Stein" release, with predicted minimum versions setting libvirt to
3.0.0 and QEMU to 2.8.0.

[*] https://wiki.openstack.org/wiki/LibvirtDistroSupportMatrix

Change-Id: I872304f99e3401f9c09d61b5511300ef9c5c7e8d
changes/71/558171/4
Kashyap Chamarthy 4 years ago
parent
commit
28d337bf74
  1. 4
      nova/virt/libvirt/driver.py

4
nova/virt/libvirt/driver.py

@ -221,8 +221,8 @@ MIN_QEMU_VERSION = (2, 1, 0)
# MIN_LIBVIRT_VERSION can be updated to match this after
# NEXT_MIN_LIBVIRT_VERSION has been at a higher value for
# one cycle
NEXT_MIN_LIBVIRT_VERSION = (1, 3, 1)
NEXT_MIN_QEMU_VERSION = (2, 5, 0)
NEXT_MIN_LIBVIRT_VERSION = (3, 0, 0)
NEXT_MIN_QEMU_VERSION = (2, 8, 0)
# When the above version matches/exceeds this version
# delete it & corresponding code using it

Loading…
Cancel
Save