OpenStack Compute (Nova)
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

74 lines
2.6KB

  1. # The order of packages is significant, because pip processes them in the order
  2. # of appearance. Changing the order has an impact on the overall integration
  3. # process, which may cause wedges in the gate later.
  4. pbr!=2.1.0,>=2.0.0 # Apache-2.0
  5. SQLAlchemy!=1.1.5,!=1.1.6,!=1.1.7,!=1.1.8,>=1.0.10 # MIT
  6. decorator>=3.4.0 # BSD
  7. eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
  8. Jinja2>=2.10 # BSD License (3 clause)
  9. keystonemiddleware>=4.17.0 # Apache-2.0
  10. lxml!=3.7.0,>=3.4.1 # BSD
  11. Routes>=2.3.1 # MIT
  12. cryptography>=2.1 # BSD/Apache-2.0
  13. WebOb>=1.8.2 # MIT
  14. # NOTE(mriedem): greenlet 0.4.14 does not work with older versions of gcc on
  15. # ppc64le systems, see https://github.com/python-greenlet/greenlet/issues/136.
  16. greenlet>=0.4.10,!=0.4.14 # MIT
  17. PasteDeploy>=1.5.0 # MIT
  18. Paste>=2.0.2 # MIT
  19. PrettyTable<0.8,>=0.7.1 # BSD
  20. sqlalchemy-migrate>=0.11.0 # Apache-2.0
  21. netaddr>=0.7.18 # BSD
  22. netifaces>=0.10.4 # MIT
  23. paramiko>=2.0.0 # LGPLv2.1+
  24. Babel!=2.4.0,>=2.3.4 # BSD
  25. enum34>=1.0.4;python_version=='2.7' or python_version=='2.6' or python_version=='3.3' # BSD
  26. iso8601>=0.1.11 # MIT
  27. jsonschema<3.0.0,>=2.6.0 # MIT
  28. python-cinderclient>=3.3.0 # Apache-2.0
  29. keystoneauth1>=3.9.0 # Apache-2.0
  30. python-neutronclient>=6.7.0 # Apache-2.0
  31. python-glanceclient>=2.8.0 # Apache-2.0
  32. requests>=2.14.2 # Apache-2.0
  33. six>=1.10.0 # MIT
  34. stevedore>=1.20.0 # Apache-2.0
  35. setuptools!=24.0.0,!=34.0.0,!=34.0.1,!=34.0.2,!=34.0.3,!=34.1.0,!=34.1.1,!=34.2.0,!=34.3.0,!=34.3.1,!=34.3.2,!=36.2.0,>=21.0.0 # PSF/ZPL
  36. websockify>=0.8.0 # LGPLv3
  37. oslo.cache>=1.26.0 # Apache-2.0
  38. oslo.concurrency>=3.26.0 # Apache-2.0
  39. oslo.config>=6.1.0 # Apache-2.0
  40. oslo.context>=2.19.2 # Apache-2.0
  41. oslo.log>=3.36.0 # Apache-2.0
  42. oslo.reports>=1.18.0 # Apache-2.0
  43. oslo.serialization!=2.19.1,>=2.21.1 # Apache-2.0
  44. oslo.upgradecheck>=0.1.1
  45. oslo.utils>=3.37.0 # Apache-2.0
  46. oslo.db>=4.44.0 # Apache-2.0
  47. oslo.rootwrap>=5.8.0 # Apache-2.0
  48. oslo.messaging>=6.3.0 # Apache-2.0
  49. oslo.policy>=1.35.0 # Apache-2.0
  50. oslo.privsep>=1.23.0 # Apache-2.0
  51. oslo.i18n>=3.15.3 # Apache-2.0
  52. oslo.service>=1.34.0 # Apache-2.0
  53. rfc3986>=1.1.0 # Apache-2.0
  54. oslo.middleware>=3.31.0 # Apache-2.0
  55. psutil>=3.2.2 # BSD
  56. oslo.versionedobjects>=1.33.3 # Apache-2.0
  57. os-brick>=2.6.1 # Apache-2.0
  58. os-traits>=0.4.0 # Apache-2.0
  59. os-vif>=1.14.0 # Apache-2.0
  60. os-win>=3.0.0 # Apache-2.0
  61. castellan>=0.16.0 # Apache-2.0
  62. microversion-parse>=0.2.1 # Apache-2.0
  63. os-xenapi>=0.3.3 # Apache-2.0
  64. tooz>=1.58.0 # Apache-2.0
  65. cursive>=0.2.1 # Apache-2.0
  66. pypowervm>=1.1.15 # Apache-2.0
  67. retrying>=1.3.3,!=1.3.0 # Apache-2.0
  68. os-service-types>=1.2.0 # Apache-2.0
  69. taskflow>=2.16.0 # Apache-2.0
  70. python-dateutil>=2.5.3 # BSD
  71. zVMCloudConnector>=1.1.1;sys_platform!='win32' # Apache 2.0 License
  72. futurist>=1.8.0 # Apache-2.0