Browse Source

Update octavia-dashboard tox for stestr

This patch updates the octavia-dashboard tox environment to use stestr.

Depends-On: https://review.openstack.org/570260
Change-Id: I122cd42fea3972d2e9488a1c4239e061edb8a54b
changes/53/570253/10
Michael Johnson 3 years ago
committed by Jacky Hu
parent
commit
63841ad797
  1. 3
      .stestr.conf
  2. 7
      .testr.conf
  3. 2
      doc/requirements.txt
  4. 1
      lower-constraints.txt
  5. 3
      octavia_dashboard/karma.conf.js
  6. 2
      test-requirements.txt
  7. 6
      tox.ini

3
.stestr.conf

@ -0,0 +1,3 @@
[DEFAULT]
test_path=${OS_TEST_PATH:-./octavia_dashboard/tests/}
top_dir=./

7
.testr.conf

@ -1,7 +0,0 @@
[DEFAULT]
test_command=OS_STDOUT_CAPTURE=${OS_STDOUT_CAPTURE:-1} \
OS_STDERR_CAPTURE=${OS_STDERR_CAPTURE:-1} \
OS_TEST_TIMEOUT=${OS_TEST_TIMEOUT:-60} \
${PYTHON:-python} -m subunit.run discover -t ./ . $LISTOPT $IDOPTION
test_id_option=--load-list $IDFILE
test_list_option=--list

2
doc/requirements.txt

@ -4,4 +4,4 @@
openstackdocstheme>=1.18.1 # Apache-2.0
reno>=2.5.0 # Apache-2.0
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinxcontrib-apidoc # BSD
sphinxcontrib-apidoc>=0.2.1 # BSD

1
lower-constraints.txt

@ -107,6 +107,7 @@ semantic-version==2.3.1
simplejson==3.5.1
six==1.10.0
statsd==3.2.1
stestr==2.0.0
stevedore==1.20.0
tenacity==3.2.1
testrepository==0.0.18

3
octavia_dashboard/karma.conf.js

@ -140,7 +140,8 @@ module.exports = function (config) {
coverageReporter: {
type: 'html',
dir: '../coverage-karma/'
dir: '../cover/',
subdir: '.'
},
// Coverage threshold values.

2
test-requirements.txt

@ -8,7 +8,7 @@ django-nose>=1.4.4 # BSD
nose-exclude>=0.3.0 # LGPL
selenium>=2.50.1 # Apache-2.0
oslotest>=3.2.0 # Apache-2.0
testrepository>=0.0.18 # Apache-2.0/BSD
stestr>=2.0.0 # Apache-2.0
testscenarios>=0.4 # Apache-2.0/BSD
testtools>=2.2.0 # MIT
# This also needs xvfb library installed on your OS

6
tox.ini

@ -32,7 +32,11 @@ commands = {posargs}
[testenv:cover]
basepython = python3
commands = python setup.py test --coverage --testr-args='{posargs}'
# npm must be installed on the system, for example
# sudo apt-get install npm
# sudo yum install npm (on RHEL/CentOS, enable EPEL repository)
commands = npm install
npm test
[testenv:docs]
basepython = python3

Loading…
Cancel
Save