Browse Source

Fix Django version in lower-constraints

horizon requires Django>=1.11 but lower-constraints.txt in ocatavia-dashboard
uses Django 1.8. As a result, the latest Django 3.0.1 which is not supported
in horizon yet is installed when installing horizon as sibling.
This leads to a failure in lower-constraints job like [1].

[1] https://zuul.opendev.org/t/openstack/build/5ad97e34d5674d00af0713d57c02f616

Differences from the master branch
----------------------------------

requiremens.txt and lower-constraints.txt are updated to match
horizon's requirements in stable/stein.

Differences from the stable/train branch
----------------------------------------

sphinx in doc/requirements.txt is upated to match global-requirements.txt

Change-Id: I7f8db57600b39e4f230261e15d103b1d32968b38
(cherry picked from commit 86fb321f34)
(cherry picked from commit 64221cd6ab)
changes/21/700721/3
Akihiro Motoki 1 month ago
parent
commit
97c10411a6
3 changed files with 9 additions and 8 deletions
  1. +2
    -1
      doc/requirements.txt
  2. +6
    -6
      lower-constraints.txt
  3. +1
    -1
      requirements.txt

+ 2
- 1
doc/requirements.txt View File

@@ -3,5 +3,6 @@
# process, which may cause wedges in the gate later.
openstackdocstheme>=1.18.1 # Apache-2.0
reno>=2.5.0 # Apache-2.0
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
sphinxcontrib-apidoc>=0.2.1 # BSD

+ 6
- 6
lower-constraints.txt View File

@@ -12,9 +12,9 @@ cryptography==2.1
debtcollector==1.2.0
decorator==3.4.0
deprecation==1.0
Django==1.8
Django==1.11
django-appconf==1.0.2
django-babel==0.5.1
django-babel==0.6.2
django-compressor==2.0
django-pyscss==2.0.2
dogpile.cache==0.6.2
@@ -26,7 +26,7 @@ flake8==2.5.5
futurist==1.2.0
greenlet==0.4.10
hacking==0.12.0
horizon==13.0.0
horizon==15.0.0
idna==2.6
iso8601==0.1.11
Jinja2==2.10
@@ -50,7 +50,7 @@ openstacksdk==0.24.0
os-client-config==1.28.0
os-service-types==1.2.0
osc-lib==1.8.0
oslo.concurrency==3.25.0
oslo.concurrency==3.26.0
oslo.config==5.2.0
oslo.context==2.19.2
oslo.i18n==3.15.3
@@ -62,7 +62,7 @@ oslo.serialization==2.18.0
oslo.service==1.24.0
oslo.utils==3.33.0
oslotest==3.2.0
osprofiler==1.4.0
osprofiler==2.3.0
Paste==2.0.2
PasteDeploy==1.5.0
pbr==2.0.0
@@ -81,7 +81,7 @@ pyparsing==2.1.0
pyperclip==1.5.27
pyScss==1.3.4
python-barbicanclient==4.5.2
python-cinderclient==3.3.0
python-cinderclient==4.0.1
python-dateutil==2.5.3
python-glanceclient==2.8.0
python-keystoneclient==3.8.0

+ 1
- 1
requirements.txt View File

@@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.

horizon>=14.0.0.0b3 # Apache-2.0
horizon>=15.0.0 # Apache-2.0
Babel!=2.4.0,>=2.3.4 # BSD
openstacksdk>=0.24.0 # Apache-2.0
oslo.log>=3.36.0 # Apache-2.0

Loading…
Cancel
Save