Browse Source

Do not install tempest plugin in train environments

Since train is a python2 env, expand the check in the
devstack plugin to not install the tempest plugin since
it is python3-only.

Change-Id: I67027090a8cc340b85fb1119f0e52bc1f2ffc66d
changes/28/763228/3
Brian Haley 5 months ago
parent
commit
08182055bc
1 changed files with 4 additions and 4 deletions
  1. +4
    -4
      devstack/plugin.sh

+ 4
- 4
devstack/plugin.sh View File

@ -28,11 +28,11 @@ if [[ "$1" == "stack" ]]; then
case "$2" in
install)
# Install dev library if
# - the release is more recent than stein (devstack in stein would
# try to install it in a python2 env, but octavia-tempest-plugin is
# now a python3-only project)
# - the release is more recent than train (devstack in train would
# try to install it in a python2 env, but octavia-tempest-plugin
# is now a python3-only project)
# - or the user explicitly requests it (INSTALL_TEMPEST=True)
if [[ "$DEVSTACK_SERIES" != "stein" ]] || [[ "$(trueorfalse False INSTALL_TEMPEST)" == "True" ]]; then
if [[ ! "$DEVSTACK_SERIES" =~ (stein|train) ]] || [[ "$(trueorfalse False INSTALL_TEMPEST)" == "True" ]]; then
echo_summary "Installing octavia-tempest-plugin"
install_octavia_tempest_plugin
fi


Loading…
Cancel
Save