Bump diskimage-builder minimum to 2.24.0

There was a bug[1] in diskimage-builder when using pypi mirrors
if the host doesn't have "python" available DIB will fail.
So, I am going to bump the requirements minimum in Octavia for
diskimage-builder to be the minimum version with this fix.

[1] https://bugs.launchpad.net/diskimage-builder/+bug/1577105

Change-Id: If0ff2a855ad5b9d9ef3742ad0596c97a6dbf81ed
changes/33/680833/3
Michael Johnson 3 years ago
parent 09efc2a423
commit 1aeb416a7e
  1. 2
      diskimage-create/requirements.txt
  2. 2
      lower-constraints.txt
  3. 2
      requirements.txt

@ -1,4 +1,4 @@
Babel>=1.3
diskimage-builder
diskimage-builder>=2.24.0
PyYAML
six>=1.9.0

@ -24,7 +24,7 @@ cryptography==2.1
debtcollector==1.19.0
decorator==4.2.1
deprecation==2.0
diskimage-builder==1.1.2
diskimage-builder==2.24.0
distro===1.2.0
doc8==0.6.0
docutils==0.14

@ -38,7 +38,7 @@ pyOpenSSL>=17.1.0 # Apache-2.0
WSME>=0.8.0 # MIT
Jinja2>=2.10 # BSD License (3 clause)
taskflow>=2.16.0 # Apache-2.0
diskimage-builder!=1.6.0,!=1.7.0,!=1.7.1,>=1.1.2 # Apache-2.0
diskimage-builder>=2.24.0 # Apache-2.0
futures>=3.0.0;python_version=='2.7' or python_version=='2.6' # BSD
castellan>=0.16.0 # Apache-2.0
tenacity>=5.0.4 # Apache-2.0

Loading…
Cancel
Save