Browse Source

Cap jsonschema 3.2.0 as the minimal version

Previous versions of jsonschema (<3.2.0) doesn't support python 3.8 [1].
Python 3.8 is part of the victoria supported runtimes [2] so we now force
to use jsonschema version 3.2.0 to avoid issues, remove ambiguity and ensure
that everything works with python 3 in general.

[1] https://github.com/Julian/jsonschema/pull/627
[2] https://governance.openstack.org/tc/reference/runtimes/victoria.html#python-runtimes-for-victoria

Change-Id: I2816360b59f82c996038929ed6e90b744feb3f75
changes/61/730961/2
Hervé Beraud 2 years ago
parent
commit
8119b21452
  1. 2
      lower-constraints.txt
  2. 2
      requirements.txt

2
lower-constraints.txt

@ -53,7 +53,7 @@ Jinja2==2.10
jmespath==0.9.3
jsonpatch==1.21
jsonpointer==2.0
jsonschema==2.6.0
jsonschema==3.2.0
keystoneauth1==3.4.0
keystonemiddleware==4.17.0
kombu==4.1.0

2
requirements.txt

@ -42,7 +42,7 @@ diskimage-builder>=2.24.0 # Apache-2.0
castellan>=0.16.0 # Apache-2.0
tenacity>=5.0.4 # Apache-2.0
distro>=1.2.0 # Apache-2.0
jsonschema>=2.6.0 # MIT
jsonschema>=3.2.0 # MIT
octavia-lib>=2.0.0 # Apache-2.0
netaddr>=0.7.19 # BSD
simplejson>=3.13.2 # MIT

Loading…
Cancel
Save