Browse Source

Fix lower-constraints

Bump several requirements to unlock gates.

Change-Id: I5edd05f549d4317b2c6186c35c6fc64cb54facac
changes/64/768464/3
Ann Kamyshnikova 9 months ago
committed by Ann Taraday
parent
commit
e5c8aeffd6
  1. 31
      lower-constraints.txt
  2. 6
      requirements.txt
  3. 2
      test-requirements.txt

31
lower-constraints.txt

@ -1,9 +1,9 @@
alabaster==0.7.10
alembic==0.8.10
amqp==2.2.2
alembic==0.9.6
amqp==2.5.2
appdirs==1.4.3
asn1crypto==0.24.0
astroid==1.3.8
astroid==2.0.0
automaton==1.14.0
bandit==1.4.0
bashate==0.5.1
@ -33,7 +33,7 @@ eventlet==0.20.0
extras==1.0.0
fasteners==0.14.1
fixtures==3.0.0
flake8==2.5.5
flake8==3.6.0
flake8-import-order==0.12
Flask==0.10
future==0.16.0
@ -43,7 +43,7 @@ gitdb2==2.0.3
GitPython==2.1.8
greenlet==0.4.13
gunicorn==19.9.0
hacking==1.1.0
hacking==3.0
idna==2.6
imagesize==1.0.0
ipaddress==1.0.17
@ -57,20 +57,20 @@ jsonschema==3.2.0
kazoo==2.6.0
keystoneauth1==3.4.0
keystonemiddleware==4.17.0
kombu==4.1.0
kombu==4.6.6
linecache2==1.0.0
logilab-common==1.4.1
logutils==0.3.5
Mako==1.0.7
MarkupSafe==1.0
mccabe==0.4.0
mccabe==0.6.0
monotonic==1.4
mox3==0.25.0
msgpack==0.5.6
munch==2.2.0
netaddr==0.7.19
netifaces==0.10.4
networkx==1.11
networkx==2.1.0
octavia-lib==2.2.0
openstacksdk==0.12.0
os-client-config==1.29.0
@ -87,10 +87,10 @@ oslo.messaging==12.4.0
oslo.middleware==4.0.1
oslo.policy==1.30.0
oslo.reports==1.18.0
oslo.serialization==2.18.0
oslo.serialization==2.28.1
oslo.service==1.30.0
oslo.upgradecheck==0.1.0
oslo.utils==3.33.0
oslo.utils==3.37.0
oslotest==3.2.0
packaging==17.1
paramiko==2.4.1
@ -106,13 +106,13 @@ psutil==5.4.3
pyasn1==0.1.8
pyasn1-modules==0.0.6
pycadf==2.7.0
pycodestyle==2.3.1
pycodestyle==2.4.0
pycparser==2.18
pydot==1.2.4
pyflakes==1.0.0
pyflakes==2.0.0
Pygments==2.2.0
pyinotify==0.9.6
pylint==1.9.2
pylint==2.2.0
PyMySQL==0.8.0
PyNaCl==1.2.1
pyOpenSSL==19.1.0
@ -141,7 +141,6 @@ Routes==2.4.1
setproctitle==1.1.10
simplegeneric==0.8.1
simplejson==3.13.2
six==1.10.0
smmap2==2.0.3
snowballstemmer==1.2.1
Sphinx==2.0.0
@ -155,7 +154,7 @@ statsd==3.2.2
stestr==2.0.0
stevedore==1.20.0
taskflow==4.4.0
tempest==17.1.0
tempest==21.0.0
Tempita==0.5.2
tenacity==5.0.4
testrepository==0.0.18
@ -168,7 +167,7 @@ urllib3==1.22
vine==1.1.4
voluptuous==0.11.1
waitress==1.1.0
warlock==1.3.0
warlock==1.3.1
WebOb==1.8.2
WebTest==2.0.29
Werkzeug==0.14.1

6
requirements.txt

@ -1,7 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
alembic>=0.8.10 # MIT
alembic>=0.9.6 # MIT
cotyledon>=1.3.0 # Apache-2.0
pecan>=1.3.2 # BSD
pbr!=2.1.0,>=2.0.0 # Apache-2.0
@ -24,9 +24,9 @@ oslo.messaging>=12.4.0 # Apache-2.0
oslo.middleware>=4.0.1 # Apache-2.0
oslo.policy>=1.30.0 # Apache-2.0
oslo.reports>=1.18.0 # Apache-2.0
oslo.serialization!=2.19.1,>=2.18.0 # Apache-2.0
oslo.serialization>=2.28.1 # Apache-2.0
oslo.upgradecheck>=0.1.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
oslo.utils>=3.37.0 # Apache-2.0
pyasn1!=0.2.3,>=0.1.8 # BSD
pyasn1-modules>=0.0.6 # BSD
python-barbicanclient>=4.5.2 # Apache-2.0

2
test-requirements.txt

@ -15,7 +15,7 @@ testresources>=2.0.0 # Apache-2.0/BSD
testscenarios>=0.4 # Apache-2.0/BSD
doc8>=0.6.0 # Apache-2.0
bandit!=1.6.0,>=1.1.0 # Apache-2.0
tempest>=17.1.0 # Apache-2.0
tempest>=21.0.0 # Apache-2.0
# Required for pep8 - doc8 tests
sphinx>=2.0.0,!=2.1.0 # BSD
bashate>=0.5.1 # Apache-2.0
Loading…
Cancel
Save