Browse Source

Cap hacking version to <2

Hacking received a major update to version 2.0.0 that added new checks
that fail on stable branches. Instead of addressing those new check
errors on stable branches, it is better to cap hacking to <2. This way
we'll not see lint errors again should new checks be added in the
future.

Support for hacking 2.0.0 in master branch is being worked in
https://review.opendev.org/#/c/699302/

Change-Id: I4706972095d42815a3f3cec0bc5aa82a34922bf3
(cherry picked from commit 85f7abbbaf)
(cherry picked from commit d0ef7a8231)
(cherry picked from commit 1768b17c03)
changes/41/702041/1
Carlos Goncalves 1 month ago
parent
commit
ea4ae88378
1 changed files with 1 additions and 1 deletions
  1. +1
    -1
      test-requirements.txt

+ 1
- 1
test-requirements.txt View File

@@ -1,7 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
hacking!=0.13.0,<0.14,>=0.12.0,<2 # Apache-2.0
requests-mock>=1.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
flake8-import-order==0.12 # LGPLv3

Loading…
Cancel
Save