Browse Source

Install missing libxml2 distro package

In order to run the glance-api service, the libxml2 library is required,
or the following error will be returned when starting the service:

error while loading shared libraries: libxml2.so.2: cannot open shared object file

To ensure that the library is installed, we add the required package to
the base glance packages.

Depends-On: https://review.openstack.org/613030
Change-Id: I4f2c5df598473152bf319296355b57f4826b3554
Jesse Pretorius 6 months ago
parent
commit
c5e7333610
3 changed files with 3 additions and 0 deletions
  1. 1
    0
      vars/redhat-7.yml
  2. 1
    0
      vars/suse.yml
  3. 1
    0
      vars/ubuntu.yml

+ 1
- 0
vars/redhat-7.yml View File

@@ -15,6 +15,7 @@
15 15
 
16 16
 glance_distro_packages:
17 17
   - git
18
+  - libxml2
18 19
   - nfs-utils
19 20
   - rpcbind
20 21
 

+ 1
- 0
vars/suse.yml View File

@@ -16,6 +16,7 @@
16 16
 
17 17
 glance_distro_packages:
18 18
   - git-core
19
+  - libxml2
19 20
   - nfs-utils
20 21
   - rpcbind
21 22
 

+ 1
- 0
vars/ubuntu.yml View File

@@ -19,6 +19,7 @@ cache_timeout: 600
19 19
 # Common apt packages
20 20
 glance_distro_packages:
21 21
   - git
22
+  - libxml2
22 23
   - nfs-common
23 24
   - rpcbind
24 25
 

Loading…
Cancel
Save