Browse Source

Consider prereleases when working with pip

Add --pre to the pip install options. Otherwise, prerelease versions are
not accepted by pip to resolve dependencies and problems appear when
building the venvs. For example tacker venv build fails with:

Could not find a version that satisfies the requirement neutron>=12.0.0

and we have neutron=13.0.0.0b3.dev94

Change-Id: I0dcb390a189b9fcad4dc5990b03c99ef30b4bbe4
Signed-off-by: Manuel Buil <mbuil@suse.com>
Manuel Buil 8 months ago
parent
commit
88d817836e
1 changed files with 1 additions and 0 deletions
  1. 1
    0
      defaults/main.yml

+ 1
- 0
defaults/main.yml View File

@@ -96,6 +96,7 @@ repo_build_venv_dir: "{{ repo_build_base_path }}/venvs/{{ repo_build_release_tag
96 96
 repo_build_venv_pip_install_options: >-
97 97
   --timeout 120
98 98
   --find-links {{ repo_build_release_path }}
99
+  --pre
99 100
 
100 101
 # NOTE(odyssey4me):
101 102
 # Not using --always-copy for CentOS/SuSE due to

Loading…
Cancel
Save