Browse Source

Use py3 as the default runtime for tox

Moving on py3 as the default runtime for tox to avoid to update this at
each new cycle.

Wallaby support officially the following runtimes [1]:
- Python 3.6
- Python 3.8

During Victoria Python 3.7 was used as the default runtime [2] however this
version isn't longer officially supported.

[1] https://governance.openstack.org/tc/reference/runtimes/wallaby.html#python-runtimes-for-wallaby
[2] https://governance.openstack.org/tc/reference/runtimes/victoria.html#python-runtimes-for-victoria

Change-Id: I07c86686aa5bdd8658616c901cba262e4394bb12
changes/24/761324/1
Hervé Beraud 2 years ago
parent
commit
31c0b1901c
  1. 2
      tox.ini

2
tox.ini

@ -1,6 +1,6 @@
[tox]
minversion = 3.1.0
envlist = py38,pep8
envlist = py3,pep8
skipsdist = True
# Automatic envs (pyXX) will only use the python version appropriate to that
# env and ignore basepython inherited from [testenv] if we set

Loading…
Cancel
Save