Tools used by OpenStack Documentation
Du kannst nicht mehr als 25 Themen auswählen Themen müssen mit entweder einem Buchstaben oder einer Ziffer beginnen. Sie können Bindestriche („-“) enthalten und bis zu 35 Zeichen lang sein.
Zuul 2b275421b0 Merge "Remove openstack-jsoncheck and openstack-indexpage" vor 1 Monat
bin Cleanup doc-tools-check-languages vor 1 Monat
doc/source Merge "Remove some commented obsolete lines" vor 1 Monat
os_doc_tools Remove openstack-jsoncheck and openstack-indexpage vor 1 Monat
releasenotes Remove openstack-jsoncheck and openstack-indexpage vor 1 Monat
sitemap Update docs building vor 1 Monat
test Remove openstack-jsoncheck and openstack-indexpage vor 1 Monat
.gitignore Switch to stestr vor 1 Jahr
.gitreview OpenDev Migration Patch vor 5 Monaten
.mailmap Add .mailmap vor 5 Jahren
.stestr.conf Switch to stestr vor 1 Jahr
.zuul.yaml Add Python 3 Train unit tests vor 2 Monaten
CONTRIBUTING.rst Note to add 'jinja2' and 'markupsafe' to requirements vor 3 Jahren
HACKING.rst Fix URLs vor 2 Jahren
LICENSE Add LICENSE and README.rst vor 5 Jahren
README.rst Replace git.openstack.org URLs with opendev.org URLs vor 5 Monaten
RELEASE_NOTES.rst Fix URLs vor 2 Jahren
bindep.txt add lower-constraints job vor 1 Jahr
lower-constraints.txt Update docs building vor 1 Monat
requirements.txt Update docs building vor 1 Monat
setup.cfg Remove openstack-jsoncheck and openstack-indexpage vor 1 Monat
setup.py Updated from global requirements vor 2 Jahren
test-requirements.txt Update docs building vor 1 Monat
tox.ini Update docs building vor 1 Monat

README.rst

Team and repository tags

image

OpenStack Doc Tools

This repository contains tools used by the OpenStack Documentation project.

For more details, see the OpenStack Documentation Contributor Guide.

Prerequisites

You need to have Python 2.7 installed for using the tools.

This package needs a few external dependencies including lxml. If you do not have lxml installed, you can either install python-lxml or have it installed automatically and build from sources. To build lxml from sources, you need a C compiler and the xml and xslt development packages installed.

To install python-lxml, execute the following based on your distribution.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-lxml

On openSUSE:

$ zypper in python-lxml

On Ubuntu:

$ apt-get install python-lxml

For building from source, install the dependencies of lxml.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-devel libxml2-devel libxslt-devel

On openSUSE:

$ zypper in libxslt-devel

On Ubuntu:

$ apt-get install libxml2-dev libxslt-dev