Tools used by OpenStack Documentation
No puede seleccionar más de 25 temas Los temas deben comenzar con una letra o número, pueden incluir guiones ('-') y pueden tener hasta 35 caracteres de largo.
Andreas Jaeger 7ee77130c4 Switch to newer openstackdocstheme and reno versions hace 1 semana
bin Cleanup doc-tools-check-languages hace 9 meses
doc/source Switch to newer openstackdocstheme and reno versions hace 1 semana
os_doc_tools Remove openstack-jsoncheck and openstack-indexpage hace 9 meses
releasenotes Switch to newer openstackdocstheme and reno versions hace 1 semana
sitemap Update sitemap for Python3 hace 2 meses
test Update hacking for Python3 hace 2 meses
.gitignore Switch to stestr hace 1 año
.gitreview OpenDev Migration Patch hace 1 año
.mailmap Add .mailmap hace 6 años
.stestr.conf Switch to stestr hace 1 año
.zuul.yaml Drop python 2.7 support and testing hace 4 meses
CONTRIBUTING.rst setup.cfg: Cleanup and update some urls to latest hace 7 meses
HACKING.rst setup.cfg: Cleanup and update some urls to latest hace 7 meses
LICENSE Add LICENSE and README.rst hace 6 años
README.rst Replace git.openstack.org URLs with opendev.org URLs hace 1 año
RELEASE_NOTES.rst Fix URLs hace 2 años
bindep.txt add lower-constraints job hace 2 años
lower-constraints.txt Switch to newer openstackdocstheme and reno versions hace 1 semana
requirements.txt Switch to newer openstackdocstheme and reno versions hace 1 semana
setup.cfg Cleanup py27 support hace 2 meses
setup.py Cleanup py27 support hace 2 meses
test-requirements.txt Switch to newer openstackdocstheme and reno versions hace 1 semana
tox.ini Drop python 2.7 support and testing hace 4 meses

README.rst

Team and repository tags

image

OpenStack Doc Tools

This repository contains tools used by the OpenStack Documentation project.

For more details, see the OpenStack Documentation Contributor Guide.

Prerequisites

You need to have Python 2.7 installed for using the tools.

This package needs a few external dependencies including lxml. If you do not have lxml installed, you can either install python-lxml or have it installed automatically and build from sources. To build lxml from sources, you need a C compiler and the xml and xslt development packages installed.

To install python-lxml, execute the following based on your distribution.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-lxml

On openSUSE:

$ zypper in python-lxml

On Ubuntu:

$ apt-get install python-lxml

For building from source, install the dependencies of lxml.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-devel libxml2-devel libxslt-devel

On openSUSE:

$ zypper in libxslt-devel

On Ubuntu:

$ apt-get install libxml2-dev libxslt-dev