Tools used by OpenStack Documentation
Você não pode selecionar mais de 25 tópicos Os tópicos devem começar com uma letra ou um número, podem incluir traços ('-') e podem ter até 35 caracteres.
Andreas Jaeger 7ee77130c4 Switch to newer openstackdocstheme and reno versions 1 semana atrás
bin Cleanup doc-tools-check-languages 9 meses atrás
doc/source Switch to newer openstackdocstheme and reno versions 1 semana atrás
os_doc_tools Remove openstack-jsoncheck and openstack-indexpage 9 meses atrás
releasenotes Switch to newer openstackdocstheme and reno versions 1 semana atrás
sitemap Update sitemap for Python3 2 meses atrás
test Update hacking for Python3 2 meses atrás
.gitignore Switch to stestr 1 ano atrás
.gitreview OpenDev Migration Patch 1 ano atrás
.mailmap Add .mailmap 6 anos atrás
.stestr.conf Switch to stestr 1 ano atrás
.zuul.yaml Drop python 2.7 support and testing 4 meses atrás
CONTRIBUTING.rst setup.cfg: Cleanup and update some urls to latest 7 meses atrás
HACKING.rst setup.cfg: Cleanup and update some urls to latest 7 meses atrás
LICENSE Add LICENSE and README.rst 6 anos atrás
README.rst Replace git.openstack.org URLs with opendev.org URLs 1 ano atrás
RELEASE_NOTES.rst Fix URLs 2 anos atrás
bindep.txt add lower-constraints job 2 anos atrás
lower-constraints.txt Switch to newer openstackdocstheme and reno versions 1 semana atrás
requirements.txt Switch to newer openstackdocstheme and reno versions 1 semana atrás
setup.cfg Cleanup py27 support 2 meses atrás
setup.py Cleanup py27 support 2 meses atrás
test-requirements.txt Switch to newer openstackdocstheme and reno versions 1 semana atrás
tox.ini Drop python 2.7 support and testing 4 meses atrás

README.rst

Team and repository tags

image

OpenStack Doc Tools

This repository contains tools used by the OpenStack Documentation project.

For more details, see the OpenStack Documentation Contributor Guide.

Prerequisites

You need to have Python 2.7 installed for using the tools.

This package needs a few external dependencies including lxml. If you do not have lxml installed, you can either install python-lxml or have it installed automatically and build from sources. To build lxml from sources, you need a C compiler and the xml and xslt development packages installed.

To install python-lxml, execute the following based on your distribution.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-lxml

On openSUSE:

$ zypper in python-lxml

On Ubuntu:

$ apt-get install python-lxml

For building from source, install the dependencies of lxml.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-devel libxml2-devel libxslt-devel

On openSUSE:

$ zypper in libxslt-devel

On Ubuntu:

$ apt-get install libxml2-dev libxslt-dev