Tools used by OpenStack Documentation
Вы не можете выбрать более 25 тем Темы должны начинаться с буквы или цифры, могут содержать дефисы(-) и должны содержать не более 35 символов.
Andreas Jaeger 7ee77130c4 Switch to newer openstackdocstheme and reno versions 1 неделю назад
bin Cleanup doc-tools-check-languages 9 месяцев назад
doc/source Switch to newer openstackdocstheme and reno versions 1 неделю назад
os_doc_tools Remove openstack-jsoncheck and openstack-indexpage 9 месяцев назад
releasenotes Switch to newer openstackdocstheme and reno versions 1 неделю назад
sitemap Update sitemap for Python3 2 месяцев назад
test Update hacking for Python3 2 месяцев назад
.gitignore Switch to stestr 1 год назад
.gitreview OpenDev Migration Patch 1 год назад
.mailmap Add .mailmap 6 лет назад
.stestr.conf Switch to stestr 1 год назад
.zuul.yaml Drop python 2.7 support and testing 4 месяцев назад
CONTRIBUTING.rst setup.cfg: Cleanup and update some urls to latest 7 месяцев назад
HACKING.rst setup.cfg: Cleanup and update some urls to latest 7 месяцев назад
LICENSE Add LICENSE and README.rst 6 лет назад
README.rst Replace git.openstack.org URLs with opendev.org URLs 1 год назад
RELEASE_NOTES.rst Fix URLs 2 лет назад
bindep.txt add lower-constraints job 2 лет назад
lower-constraints.txt Switch to newer openstackdocstheme and reno versions 1 неделю назад
requirements.txt Switch to newer openstackdocstheme and reno versions 1 неделю назад
setup.cfg Cleanup py27 support 2 месяцев назад
setup.py Cleanup py27 support 2 месяцев назад
test-requirements.txt Switch to newer openstackdocstheme and reno versions 1 неделю назад
tox.ini Drop python 2.7 support and testing 4 месяцев назад

README.rst

Team and repository tags

image

OpenStack Doc Tools

This repository contains tools used by the OpenStack Documentation project.

For more details, see the OpenStack Documentation Contributor Guide.

Prerequisites

You need to have Python 2.7 installed for using the tools.

This package needs a few external dependencies including lxml. If you do not have lxml installed, you can either install python-lxml or have it installed automatically and build from sources. To build lxml from sources, you need a C compiler and the xml and xslt development packages installed.

To install python-lxml, execute the following based on your distribution.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-lxml

On openSUSE:

$ zypper in python-lxml

On Ubuntu:

$ apt-get install python-lxml

For building from source, install the dependencies of lxml.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-devel libxml2-devel libxslt-devel

On openSUSE:

$ zypper in libxslt-devel

On Ubuntu:

$ apt-get install libxml2-dev libxslt-dev