Tools used by OpenStack Documentation
25'ten fazla konu seçemezsiniz Konular bir harf veya rakamla başlamalı, kısa çizgiler ('-') içerebilir ve en fazla 35 karakter uzunluğunda olabilir.
Andreas Jaeger 7ee77130c4 Switch to newer openstackdocstheme and reno versions 1 hafta önce
bin Cleanup doc-tools-check-languages 9 ay önce
doc/source Switch to newer openstackdocstheme and reno versions 1 hafta önce
os_doc_tools Remove openstack-jsoncheck and openstack-indexpage 9 ay önce
releasenotes Switch to newer openstackdocstheme and reno versions 1 hafta önce
sitemap Update sitemap for Python3 2 ay önce
test Update hacking for Python3 2 ay önce
.gitignore Switch to stestr 1 yıl önce
.gitreview OpenDev Migration Patch 1 yıl önce
.mailmap Add .mailmap 6 yıl önce
.stestr.conf Switch to stestr 1 yıl önce
.zuul.yaml Drop python 2.7 support and testing 4 ay önce
CONTRIBUTING.rst setup.cfg: Cleanup and update some urls to latest 7 ay önce
HACKING.rst setup.cfg: Cleanup and update some urls to latest 7 ay önce
LICENSE Add LICENSE and README.rst 6 yıl önce
README.rst Replace git.openstack.org URLs with opendev.org URLs 1 yıl önce
RELEASE_NOTES.rst Fix URLs 2 yıl önce
bindep.txt add lower-constraints job 2 yıl önce
lower-constraints.txt Switch to newer openstackdocstheme and reno versions 1 hafta önce
requirements.txt Switch to newer openstackdocstheme and reno versions 1 hafta önce
setup.cfg Cleanup py27 support 2 ay önce
setup.py Cleanup py27 support 2 ay önce
test-requirements.txt Switch to newer openstackdocstheme and reno versions 1 hafta önce
tox.ini Drop python 2.7 support and testing 4 ay önce

README.rst

Team and repository tags

image

OpenStack Doc Tools

This repository contains tools used by the OpenStack Documentation project.

For more details, see the OpenStack Documentation Contributor Guide.

Prerequisites

You need to have Python 2.7 installed for using the tools.

This package needs a few external dependencies including lxml. If you do not have lxml installed, you can either install python-lxml or have it installed automatically and build from sources. To build lxml from sources, you need a C compiler and the xml and xslt development packages installed.

To install python-lxml, execute the following based on your distribution.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-lxml

On openSUSE:

$ zypper in python-lxml

On Ubuntu:

$ apt-get install python-lxml

For building from source, install the dependencies of lxml.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-devel libxml2-devel libxslt-devel

On openSUSE:

$ zypper in libxslt-devel

On Ubuntu:

$ apt-get install libxml2-dev libxslt-dev