Tools used by OpenStack Documentation
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
KATO Tomoyuki 0d9c027183 [cli-ref] remove deprecated Block Storage API v1 преди 3 години
autogenerate_config_docs [config-ref] support cfg.PortOpt type by the generation tool преди 3 години
bin [cli-ref] add rmdir to cleanup working directory преди 3 години
cleanup Keep py3.X compatibility for urllib преди 4 години
doc/source Remove openstack-doc-test преди 4 години
os_doc_tools [cli-ref] remove deprecated Block Storage API v1 преди 3 години
releasenotes Remove openstack-doc-test преди 4 години
sitemap doc-tools unit tests преди 3 години
.gitignore doc-tools unit tests преди 3 години
.gitreview Add .gitreview преди 6 години
.mailmap Add .mailmap преди 6 години
.testr.conf doc-tools unit tests преди 3 години
CONTRIBUTING.rst Note to add 'jinja2' and 'markupsafe' to requirements преди 4 години
HACKING.rst doc-tools unit tests преди 3 години
LICENSE Add LICENSE and README.rst преди 6 години
MANIFEST.in Move release notes into a separate file преди 5 години
README.rst Remove openstack-doc-test преди 4 години
RELEASE_NOTES.rst Update RELEASE Notes преди 4 години
doc-test.conf.sample Allow setting of publish directory преди 6 години
openstack-common.conf Remove venv tools преди 5 години
pylintrc Add pylint target for testing преди 6 години
requirements.txt Updated from global requirements преди 3 години
setup.cfg Remove openstack-doc-test преди 4 години
setup.py Updated from global requirements преди 4 години
test-requirements.txt doc-tools unit tests преди 3 години
tox.ini doc-tools unit tests преди 3 години

README.rst

OpenStack Doc Tools

This repository contains tools used by the OpenStack Documentation project.

For more details, see the OpenStack Documentation wiki page.

Prerequisites

You need to have Python 2.7 installed for using the tools.

This package needs a few external dependencies including lxml. If you do not have lxml installed, you can either install python-lxml or have it installed automatically and build from sources. To build lxml from sources, you need a C compiler and the xml and xslt development packages installed.

To install python-lxml, execute the following based on your distribution.

On Fedora:

yum install python-lxml

On openSUSE:

zypper in python-lxml

On Ubuntu:

apt-get install python-lxml

For building from source, install the dependencies of lxml.

On Fedora:

yum install python-devel libxml2-devel libxslt-devel

On openSUSE:

zypper in libxslt-devel

On Ubuntu:

apt-get install libxml2-dev libxslt-dev