Tools used by OpenStack Documentation
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
Percila c050836a8f doc-tools unit tests 3 years ago
autogenerate_config_docs Merge "[config-ref] skip options marked as disable" 3 years ago
bin doc-tools unit tests 3 years ago
cleanup Keep py3.X compatibility for urllib 3 years ago
doc/source Remove openstack-doc-test 3 years ago
os_doc_tools doc-tools unit tests 3 years ago
releasenotes Remove openstack-doc-test 3 years ago
sitemap doc-tools unit tests 3 years ago
.gitignore doc-tools unit tests 3 years ago
.gitreview Add .gitreview 6 years ago
.mailmap Add .mailmap 5 years ago
.testr.conf doc-tools unit tests 3 years ago
CONTRIBUTING.rst Note to add 'jinja2' and 'markupsafe' to requirements 3 years ago
HACKING.rst doc-tools unit tests 3 years ago
LICENSE Add LICENSE and README.rst 6 years ago
MANIFEST.in Move release notes into a separate file 5 years ago
README.rst Remove openstack-doc-test 3 years ago
RELEASE_NOTES.rst Update RELEASE Notes 4 years ago
doc-test.conf.sample Allow setting of publish directory 5 years ago
openstack-common.conf Remove venv tools 4 years ago
pylintrc Add pylint target for testing 5 years ago
requirements.txt Updated from global requirements 3 years ago
setup.cfg Remove openstack-doc-test 3 years ago
setup.py Updated from global requirements 4 years ago
test-requirements.txt doc-tools unit tests 3 years ago
tox.ini doc-tools unit tests 3 years ago

README.rst

OpenStack Doc Tools

This repository contains tools used by the OpenStack Documentation project.

For more details, see the OpenStack Documentation wiki page.

Prerequisites

You need to have Python 2.7 installed for using the tools.

This package needs a few external dependencies including lxml. If you do not have lxml installed, you can either install python-lxml or have it installed automatically and build from sources. To build lxml from sources, you need a C compiler and the xml and xslt development packages installed.

To install python-lxml, execute the following based on your distribution.

On Fedora:

yum install python-lxml

On openSUSE:

zypper in python-lxml

On Ubuntu:

apt-get install python-lxml

For building from source, install the dependencies of lxml.

On Fedora:

yum install python-devel libxml2-devel libxslt-devel

On openSUSE:

zypper in libxslt-devel

On Ubuntu:

apt-get install libxml2-dev libxslt-dev