Tools used by OpenStack Documentation
Nie możesz wybrać więcej, niż 25 tematów Tematy muszą się zaczynać od litery lub cyfry, mogą zawierać myślniki ('-') i mogą mieć do 35 znaków.
Zuul ea541c2e7b Merge "setup.cfg: Cleanup and update some urls to latest" 7 miesięcy temu
bin Cleanup doc-tools-check-languages 9 miesięcy temu
doc/source Merge "Remove some commented obsolete lines" 9 miesięcy temu
os_doc_tools Remove openstack-jsoncheck and openstack-indexpage 9 miesięcy temu
releasenotes Remove openstack-jsoncheck and openstack-indexpage 9 miesięcy temu
sitemap Update docs building 9 miesięcy temu
test Remove openstack-jsoncheck and openstack-indexpage 9 miesięcy temu
.gitignore Switch to stestr 1 rok temu
.gitreview OpenDev Migration Patch 1 rok temu
.mailmap Add .mailmap 6 lat temu
.stestr.conf Switch to stestr 1 rok temu
.zuul.yaml Switch to ussuri python3 jobs 7 miesięcy temu
CONTRIBUTING.rst setup.cfg: Cleanup and update some urls to latest 7 miesięcy temu
HACKING.rst setup.cfg: Cleanup and update some urls to latest 7 miesięcy temu
LICENSE Add LICENSE and README.rst 6 lat temu
README.rst Replace git.openstack.org URLs with opendev.org URLs 1 rok temu
RELEASE_NOTES.rst Fix URLs 2 lat temu
bindep.txt add lower-constraints job 2 lat temu
lower-constraints.txt Update docs building 9 miesięcy temu
requirements.txt Update docs building 9 miesięcy temu
setup.cfg setup.cfg: Cleanup and update some urls to latest 7 miesięcy temu
setup.py Updated from global requirements 3 lat temu
test-requirements.txt Update docs building 9 miesięcy temu
tox.ini Update the constraints url 8 miesięcy temu

README.rst

Team and repository tags

image

OpenStack Doc Tools

This repository contains tools used by the OpenStack Documentation project.

For more details, see the OpenStack Documentation Contributor Guide.

Prerequisites

You need to have Python 2.7 installed for using the tools.

This package needs a few external dependencies including lxml. If you do not have lxml installed, you can either install python-lxml or have it installed automatically and build from sources. To build lxml from sources, you need a C compiler and the xml and xslt development packages installed.

To install python-lxml, execute the following based on your distribution.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-lxml

On openSUSE:

$ zypper in python-lxml

On Ubuntu:

$ apt-get install python-lxml

For building from source, install the dependencies of lxml.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-devel libxml2-devel libxslt-devel

On openSUSE:

$ zypper in libxslt-devel

On Ubuntu:

$ apt-get install libxml2-dev libxslt-dev