Tools used by OpenStack Documentation
Du kannst nicht mehr als 25 Themen auswählen Themen müssen entweder mit einem Buchstaben oder einer Ziffer beginnen. Sie können Bindestriche („-“) enthalten und bis zu 35 Zeichen lang sein.
Andreas Jaeger 7ee77130c4 Switch to newer openstackdocstheme and reno versions vor 1 Woche
bin Cleanup doc-tools-check-languages vor 9 Monaten
doc/source Switch to newer openstackdocstheme and reno versions vor 1 Woche
os_doc_tools Remove openstack-jsoncheck and openstack-indexpage vor 9 Monaten
releasenotes Switch to newer openstackdocstheme and reno versions vor 1 Woche
sitemap Update sitemap for Python3 vor 2 Monaten
test Update hacking for Python3 vor 2 Monaten
.gitignore Switch to stestr vor 1 Jahr
.gitreview OpenDev Migration Patch vor 1 Jahr
.mailmap Add .mailmap vor 6 Jahren
.stestr.conf Switch to stestr vor 1 Jahr
.zuul.yaml Drop python 2.7 support and testing vor 4 Monaten
CONTRIBUTING.rst setup.cfg: Cleanup and update some urls to latest vor 7 Monaten
HACKING.rst setup.cfg: Cleanup and update some urls to latest vor 7 Monaten
LICENSE Add LICENSE and README.rst vor 6 Jahren
README.rst Replace git.openstack.org URLs with opendev.org URLs vor 1 Jahr
RELEASE_NOTES.rst Fix URLs vor 2 Jahren
bindep.txt add lower-constraints job vor 2 Jahren
lower-constraints.txt Switch to newer openstackdocstheme and reno versions vor 1 Woche
requirements.txt Switch to newer openstackdocstheme and reno versions vor 1 Woche
setup.cfg Cleanup py27 support vor 2 Monaten
setup.py Cleanup py27 support vor 2 Monaten
test-requirements.txt Switch to newer openstackdocstheme and reno versions vor 1 Woche
tox.ini Drop python 2.7 support and testing vor 4 Monaten

README.rst

Team and repository tags

image

OpenStack Doc Tools

This repository contains tools used by the OpenStack Documentation project.

For more details, see the OpenStack Documentation Contributor Guide.

Prerequisites

You need to have Python 2.7 installed for using the tools.

This package needs a few external dependencies including lxml. If you do not have lxml installed, you can either install python-lxml or have it installed automatically and build from sources. To build lxml from sources, you need a C compiler and the xml and xslt development packages installed.

To install python-lxml, execute the following based on your distribution.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-lxml

On openSUSE:

$ zypper in python-lxml

On Ubuntu:

$ apt-get install python-lxml

For building from source, install the dependencies of lxml.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-devel libxml2-devel libxslt-devel

On openSUSE:

$ zypper in libxslt-devel

On Ubuntu:

$ apt-get install libxml2-dev libxslt-dev