Tools used by OpenStack Documentation
Vous ne pouvez pas sélectionner plus de 25 sujets Les noms de sujets doivent commencer par une lettre ou un nombre, peuvent contenir des tirets ('-') et peuvent comporter jusqu'à 35 caractères.
Corey Bryant 9d59e2087e Add Python 3 Train unit tests il y a 3 semaines
bin [lang] Fixes PUBLISH_DIR for api-quick-start il y a 1 an
doc/source Advancing the protocal of the website to HTTPS in README.rst. il y a 8 mois
os_doc_tools Remove the 'openstack-auto-commands' tool il y a 1 an
releasenotes Advancing the protocal of the website to HTTPS in README.rst. il y a 8 mois
sitemap Advancing the protocal of the website to HTTPS in README.rst. il y a 8 mois
test Change priorities for sitemap il y a 1 an
.gitignore Switch to stestr il y a 1 an
.gitreview OpenDev Migration Patch il y a 2 mois
.mailmap Add .mailmap il y a 5 ans
.stestr.conf Switch to stestr il y a 1 an
.zuul.yaml Add Python 3 Train unit tests il y a 3 semaines
CONTRIBUTING.rst Note to add 'jinja2' and 'markupsafe' to requirements il y a 3 ans
HACKING.rst Fix URLs il y a 1 an
LICENSE Add LICENSE and README.rst il y a 5 ans
README.rst Replace git.openstack.org URLs with opendev.org URLs il y a 2 mois
RELEASE_NOTES.rst Fix URLs il y a 1 an
bindep.txt add lower-constraints job il y a 1 an
lower-constraints.txt Update hacking il y a 7 mois
requirements.txt Switch to stestr il y a 1 an
setup.cfg Add Python 3 Train unit tests il y a 3 semaines
setup.py Updated from global requirements il y a 2 ans
test-requirements.txt Update hacking il y a 7 mois
tox.ini Add Python 3 Train unit tests il y a 3 semaines

README.rst

Team and repository tags

image

OpenStack Doc Tools

This repository contains tools used by the OpenStack Documentation project.

For more details, see the OpenStack Documentation Contributor Guide.

Prerequisites

You need to have Python 2.7 installed for using the tools.

This package needs a few external dependencies including lxml. If you do not have lxml installed, you can either install python-lxml or have it installed automatically and build from sources. To build lxml from sources, you need a C compiler and the xml and xslt development packages installed.

To install python-lxml, execute the following based on your distribution.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-lxml

On openSUSE:

$ zypper in python-lxml

On Ubuntu:

$ apt-get install python-lxml

For building from source, install the dependencies of lxml.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-devel libxml2-devel libxslt-devel

On openSUSE:

$ zypper in libxslt-devel

On Ubuntu:

$ apt-get install libxml2-dev libxslt-dev