Tools used by OpenStack Documentation
Nevar pievienot vairāk kā 25 tēmas Tēmai ir jāsākas ar burtu vai ciparu, tā var saturēt domu zīmes ('-') un var būt līdz 35 simboliem gara.
Corey Bryant 9d59e2087e Add Python 3 Train unit tests pirms 3 nedēļām
bin [lang] Fixes PUBLISH_DIR for api-quick-start pirms 1 gada
doc/source Advancing the protocal of the website to HTTPS in README.rst. pirms 8 mēnešiem
os_doc_tools Remove the 'openstack-auto-commands' tool pirms 1 gada
releasenotes Advancing the protocal of the website to HTTPS in README.rst. pirms 8 mēnešiem
sitemap Advancing the protocal of the website to HTTPS in README.rst. pirms 8 mēnešiem
test Change priorities for sitemap pirms 2 gadiem
.gitignore Switch to stestr pirms 1 gada
.gitreview OpenDev Migration Patch pirms 3 mēnešiem
.mailmap Add .mailmap pirms 5 gadiem
.stestr.conf Switch to stestr pirms 1 gada
.zuul.yaml Add Python 3 Train unit tests pirms 3 nedēļām
CONTRIBUTING.rst Note to add 'jinja2' and 'markupsafe' to requirements pirms 3 gadiem
HACKING.rst Fix URLs pirms 1 gada
LICENSE Add LICENSE and README.rst pirms 5 gadiem
README.rst Replace git.openstack.org URLs with opendev.org URLs pirms 2 mēnešiem
RELEASE_NOTES.rst Fix URLs pirms 1 gada
bindep.txt add lower-constraints job pirms 1 gada
lower-constraints.txt Update hacking pirms 7 mēnešiem
requirements.txt Switch to stestr pirms 1 gada
setup.cfg Add Python 3 Train unit tests pirms 3 nedēļām
setup.py Updated from global requirements pirms 2 gadiem
test-requirements.txt Update hacking pirms 7 mēnešiem
tox.ini Add Python 3 Train unit tests pirms 3 nedēļām

README.rst

Team and repository tags

image

OpenStack Doc Tools

This repository contains tools used by the OpenStack Documentation project.

For more details, see the OpenStack Documentation Contributor Guide.

Prerequisites

You need to have Python 2.7 installed for using the tools.

This package needs a few external dependencies including lxml. If you do not have lxml installed, you can either install python-lxml or have it installed automatically and build from sources. To build lxml from sources, you need a C compiler and the xml and xslt development packages installed.

To install python-lxml, execute the following based on your distribution.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-lxml

On openSUSE:

$ zypper in python-lxml

On Ubuntu:

$ apt-get install python-lxml

For building from source, install the dependencies of lxml.

On Fedora, RHEL 7, and CentOS 7:

$ yum install python-devel libxml2-devel libxslt-devel

On openSUSE:

$ zypper in libxslt-devel

On Ubuntu:

$ apt-get install libxml2-dev libxslt-dev