Pin ansible-compat<4 until we upgrade ansible-lint

There was a regression introduced in ansible-compat v4 which stopped
ansible-lint from working. This was fixed in ansible-lint 6.16.0 but
we've pinned it for so long now that there are a lot of rule
violations to fix or mark for skipping. In the interim, pin back all
new versions of ansible-compat until someone has time to fix things
or rip out ansible-lint entirely.

Change-Id: I62c3ca8731f237ba19868db5d0388d130ea0f214
Jeremy Stanley 2023-05-16 21:32:08 +00:00
parent 2e58106237
commit e21c6138cc
1 changed files with 2 additions and 3 deletions

View File

@ -6,8 +6,7 @@ hacking>=4.0.0,<5.0.0 # Apache-2.0
# ansible-lint requires ansible>=2.9
# pin until is fixed
# pin these two until someone has time to update all our skips to >=6.16
# avoid for