Browse Source

Use unittest.mock instead of third party mock

Now that we no longer support py27, we can use the standard library
unittest.mock module instead of the third party mock lib.

Change-Id: Ia5a6219d6c4cc2cb10ddaeee22b957ca85064ab9
Signed-off-by: Sean McGinnis <sean.mcginnis@gmail.com>
tags/11.2.0^0
Sean McGinnis 3 months ago
parent
commit
852795d245
No known key found for this signature in database GPG Key ID: CE7EE4BFAF8D70C8
3 changed files with 1 additions and 3 deletions
  1. +0
    -1
      lower-constraints.txt
  2. +1
    -1
      os_apply_config/tests/test_apply_config.py
  3. +0
    -1
      test-requirements.txt

+ 0
- 1
lower-constraints.txt View File

@@ -12,7 +12,6 @@ Jinja2==2.10
linecache2==1.0.0
MarkupSafe==1.0
mccabe==0.2.1
mock==2.0.0
pbr==2.0.0
pep8==1.5.7
pyflakes==0.8.1


+ 1
- 1
os_apply_config/tests/test_apply_config.py View File

@@ -17,9 +17,9 @@ import atexit
import json
import os
import tempfile
from unittest import mock

import fixtures
import mock
import testtools

from os_apply_config import apply_config


+ 0
- 1
test-requirements.txt View File

@@ -5,7 +5,6 @@ hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0

coverage!=4.4,>=4.0 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
mock>=2.0.0 # BSD
python-subunit>=1.0.0 # Apache-2.0/BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.5,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.5;python_version>='3.4' # BSD


Loading…
Cancel
Save