Browse Source

Adjust lower-constraints

Changes:
- hacking 0.12.0 -> 1.1.0
  * it was already at >=1.1.0,<1.2.0 in test-req, so updated l-c
- flake8 2.5.5 -> 2.6.0 (for hacking)
- added bandit to test-requirements and l-c
  * needed to set cap for py27

Change-Id: If8a12c18daea9513130a020d01db2c27a93c3cfc
changes/20/767920/2
Brian Rosmaita 9 months ago
parent
commit
071b527f95
  1. 5
      lower-constraints.txt
  2. 2
      test-requirements.txt

5
lower-constraints.txt

@ -2,6 +2,7 @@ alabaster==0.7.10
appdirs==1.3.0
asn1crypto==0.23.0
Babel==2.3.4
bandit==1.1.0
castellan==0.16.0
cffi==1.7.0
cliff==2.8.0
@ -16,10 +17,10 @@ eventlet==0.18.2
extras==1.0.0
fasteners==0.7.0
fixtures==3.0.0
flake8==2.5.5
flake8==2.6.0
future==0.16.0
greenlet==0.4.10
hacking==0.12.0
hacking==1.1.0
idna==2.6
imagesize==0.7.1
iso8601==0.1.11

2
test-requirements.txt

@ -15,3 +15,5 @@ testtools>=2.2.0 # MIT
stestr>=1.0.0 # Apache-2.0
oslo.vmware>=2.17.0 # Apache-2.0
castellan>=0.16.0 # Apache-2.0
bandit>=1.1.0;python_version>='3.4'
bandit>=1.1.0,<=1.6.2;python_version=='2.7'
Loading…
Cancel
Save