Browse Source

Update requirements for wallaby release

Raise the minimum versions in the various requirements files to
reflect what we're actually testing with right now.

Change-Id: Ie7dcc859e1291bd1d50b1ae516be38d8732de836
changes/07/778807/1
Brian Rosmaita 7 months ago
parent
commit
9a59547a4b
  1. 11
      doc/requirements.txt
  2. 27
      lower-constraints.txt
  3. 19
      requirements.txt
  4. 8
      test-requirements.txt

11
doc/requirements.txt

@ -1,9 +1,10 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
openstackdocstheme>=2.2.1 # Apache-2.0
reno>=3.1.0 # Apache-2.0
sphinx>=2.0.0,!=2.1.0 # BSD
os-api-ref>=1.5.0 # Apache-2.0
sphinxcontrib-apidoc>=0.2.0 # BSD
openstackdocstheme>=2.2.7 # Apache-2.0
reno>=3.2.0 # Apache-2.0
sphinx>=3.5.1 # BSD
os-api-ref>=2.1.0 # Apache-2.0
sphinxcontrib-apidoc>=0.3.0 # BSD
sphinx-feature-classification>=1.1.0 # Apache 2.0

27
lower-constraints.txt

@ -1,18 +1,18 @@
appdirs==1.3.0
asn1crypto==0.23.0
Babel==2.8.0
castellan==3.6.0
castellan==3.7.0
cffi==1.14.2
cliff==3.4.0
cmd2==1.3.8
coverage==5.2.1
coverage==5.5
cryptography==3.1
ddt==1.4.1
debtcollector==2.2.0
dnspython==1.16.0
doc8==0.8.1
entrypoints==0.3
eventlet==0.26.1
eventlet==0.30.1
extras==1.0.0
fasteners==0.14.1
fixtures==3.0.0
@ -28,21 +28,21 @@ netaddr==0.8.0
netifaces==0.10.9
os-client-config==1.28.0
os-service-types==1.7.0
os-win==5.1.0
oslo.concurrency==4.3.0
os-win==5.4.0
oslo.concurrency==4.4.0
oslo.config==8.3.2
oslo.context==3.1.1
oslo.i18n==5.0.1
oslo.log==4.4.0
oslo.privsep==2.4.0
oslo.serialization==4.0.1
oslo.service==2.4.0
oslo.utils==4.7.0
oslo.vmware==3.7.0
oslo.serialization==4.1.0
oslo.service==2.5.0
oslo.utils==4.8.0
oslo.vmware==3.8.0
oslotest==4.4.1
Paste==3.4.3
PasteDeploy==2.1.0
pbr==5.5.0
pbr==5.5.1
prettytable==0.7.2
pycparser==2.20
pyinotify==0.9.6
@ -55,15 +55,14 @@ python-subunit==1.4.0
pytz==2020.1
PyYAML==5.3.1
repoze.lru==0.7
requests==2.23.0
requests==2.25.1
requestsexceptions==1.2.0
rfc3986==1.4.0
Routes==2.4.1
six==1.15.0
stestr==3.0.1
stestr==3.1.0
stevedore==3.2.2
suds-jurko==0.6
tenacity==6.2.0
tenacity==6.3.1
testrepository==0.0.20
testscenarios==0.5.0
testtools==2.4.0

19
requirements.txt

@ -2,17 +2,16 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr>=5.5.0 # Apache-2.0
eventlet>=0.26.1 # MIT
oslo.concurrency>=4.3.0 # Apache-2.0
pbr>=5.5.1 # Apache-2.0
eventlet>=0.30.1 # MIT
oslo.concurrency>=4.4.0 # Apache-2.0
oslo.context>=3.1.1 # Apache-2.0
oslo.log>=4.4.0 # Apache-2.0
oslo.i18n>=5.0.1 # Apache-2.0
oslo.privsep>=2.4.0 # Apache-2.0
oslo.serialization>=4.0.1 # Apache-2.0
oslo.service>=2.4.0 # Apache-2.0
oslo.utils>=4.7.0 # Apache-2.0
requests>=2.23.0 # Apache-2.0
six>=1.15.0 # MIT
tenacity>=6.2.0 # Apache-2.0
os-win>=5.1.0 # Apache-2.0
oslo.serialization>=4.1.0 # Apache-2.0
oslo.service>=2.5.0 # Apache-2.0
oslo.utils>=4.8.0 # Apache-2.0
requests>=2.25.1 # Apache-2.0
tenacity>=6.3.1 # Apache-2.0
os-win>=5.4.0 # Apache-2.0

8
test-requirements.txt

@ -4,14 +4,14 @@
hacking>=4.0.0,<4.1.0 # Apache-2.0
flake8-import-order # LGPLv3
coverage>=5.2.1 # Apache-2.0
coverage>=5.5 # Apache-2.0
ddt>=1.4.1 # MIT
oslotest>=4.4.1 # Apache-2.0
testscenarios>=0.5.0 # Apache-2.0/BSD
testtools>=2.4.0 # MIT
stestr>=3.0.1 # Apache-2.0
oslo.vmware>=3.7.0 # Apache-2.0
castellan>=3.6.0 # Apache-2.0
stestr>=3.1.0 # Apache-2.0
oslo.vmware>=3.8.0 # Apache-2.0
castellan>=3.7.0 # Apache-2.0
pycodestyle==2.6.0 # MIT
doc8>=0.8.1 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
Loading…
Cancel
Save